4

I play AoE3 fine on my laptop, using my 1080p as my primary screen at home (at 1920x1080) however when I try to run it at school (again on my laptop), I get an error stating:

Initialization Failed
Direct3D initialization failed.  Possible causes:
Old or corrupted graphics driver.
Direct3D improperly installed.
Hardware acceleration disabled.
Starting the application with the workstation locked.

Please check the log file for more information.

Anyone have any ideas?

I can run the game at just about max settings just fine with my 1080p screen....

8
  • Are you using two different screen with the same computer, or do you use a school computer to try to run it? If so, are you sure directX is installed on at school?
    – Jupotter
    May 10, 2012 at 6:16
  • No, im using my laptop at school! Woops, ill edit that now... swear i put laptop in the question.... May 10, 2012 at 6:17
  • Do you have it plugged in at school ? Where you would at home ?
    – Zero
    May 10, 2012 at 8:40
  • Did you buy the game from Steam ?
    – GTX OC
    May 10, 2012 at 9:13
  • @Foxtrot Im always plugged in when running the game, at both school and home May 10, 2012 at 20:36

1 Answer 1

4

I had the same problem with Portal 2. How did I solve it? Well I had to manually specify my resolution.

Try this:

In C:\Documents and Settings\Owner\My Documents\My Games\Age of Empires 3\Users3\NewProfile3.xml file, change

[Setting Name="optiongrfxres"]screen resolution of laptop(for eg:1024x768)[/Setting]

Source(See the 7th post)

2
  • Thanks, worked fine. I updated my game, and found that this fix was part of it... But now stuck with dumb looking pause menu... May 11, 2012 at 2:00
  • Update your video card driver , disable v-sync , run the game in windowed mode (if possible) . If all else fails , reinstall the game and update it (and hope for the best) . Cheers .
    – GTX OC
    May 11, 2012 at 4:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .