52

I'm playing on a Survival world with cheats on, "easy" difficulty, and at night in-game. I didn't have a sword or anything to make a sword with, and I was starving, so I switched to Creative to give myself a stack of food and a bed to set my spawn point. When I switched back to Survival, I couldn't destroy or place blocks. I'm on single player, and my Internet is fine, and I can destroy blocks still if I switch to creative. I've tried resetting the button one, and reloading the map, and it still doesn't work. I've even tried deleting everything I gave myself in Creative. This happened before on a different world and I ended up deleting it.

This only happens on this world. How do I fix it?

If I know I'm in the correct game mode, what else can cause this? Are there different causes in multiplayer?

77

I suspect you used /gamemode 2 [player] instead of /gamemode 0 [player]. Gamemode 0 will take you back to survival, whereas gamemode 2 places you in Adventure mode, where no blocks can be destroyed, except with the right tools.

Instead of a number for the gamemode, you can use the full name (survival, creative, adventure, spectator) or an abbreviation of the name (s, c, a, sp) to avoid this mistake in the future.

  • 16
    Note that you can now use the letter s, c, or a instead of a number with /gamemode, making this mistake easier to avoid. – SevenSidedDie Jan 6 '13 at 12:49
  • 5
    Also, the /gamemode command supports the words survival, creative, and adventure, as well as s, c, and a. – Timtech Aug 17 '13 at 20:44
  • 2
    As of 1.13, this answer is obsolete, as /gamemode no longer supports abbreviations – pppery Aug 6 '18 at 14:54
  • ... also, no blocks can be destroyed even with the right tools in adventure mode in recent versions. – pppery Jul 13 at 18:53
43

Make sure that your gamemode is not set to adventure mode.

  • for regular survival mode enter : /gamemode <playername> 0
  • for creative mode enter : /gamemode <playername> 1
  • for adventure mode enter: /gamemode <playername> 2
  • for spectator mode enter: /gamemode <playername> 3

Each mode acts a bit differently

  • Survival mode is just the Minecraft as everybody knows it and this is probably the mode you want to be changing in.
  • Creative is the mode in which you have unlimited blocks and resources to build everything in your imagination. You also have the ability to fly.
  • Adventure mode is the same as survival only you dont have the ability to destroy blocks (without the proper tool).
  • Spectator mode allows you to go inside players and mobs, as well as go through world borders and go down below the surface without getting suffocated (unless you change your gamemode).

If you know you're in the correct gamemode, another possibility is that you are too close to the spawn. This typically only applies to servers if they have some sort of spawn protection enabled.

Also clicking does not break (many) blocks, you need to click and hold. This doesn't apply to Creative mode. Initially only a few block types can be feasibly broken using only your hand, including dirt/grass, sand, wood and leaves, so try left-clicking and holding and see if you can break these types of blocks.

If nothing is happening when you left click, then your mouse button might not be properly mapped. Go into Options... -> Controls... and change Attack to your mouse button, typically Button 1. (Just click twice to change it.)

Finally, if you're playing on a server, there may be synchronization issues preventing you from breaking blocks, or performing other actions. This is typically referred to as "block lag", and is caused by the server not being able to keep up with updates coming from players. There isn't much you can do about it, unfortunately.

  • Answer is outdated. 1: In 1.13, numeric gamemodes no longer work, obsoleting this answer. 2.: As of 1.8, one needs tools with the CanBreak NBT tag, rather than just the proper tool, to destroy things in adventure mode. – pppery Aug 7 '18 at 23:33
13

Make sure you hold the mouse button down.

Many players make this mistake when moving from Classic or Creative to Survival. Blocks do not break instantly, so make sure you hold the mouse button down long enough.

  • It seems the original question has been altered or merged, to the point where this comment makes absolutely zero sense anymore. The same goes for the other answers. What gives? – Hugo Zink May 18 at 15:23
3

Check the controls in the setting. They may be messed up. Simply to setting and then the controls. Then go to ATTACK and make it Button 1. Example:

enter image description here

Another reason is that you may be in Adventure Mode. Simply go into commands and type /gamemode s.

0

You might have changed your game mode to adventure (/gamemode 2), which doesn't allow you to do anything with blocks.

protected by Community Feb 11 '13 at 13:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.