This is my second play through of Mass Effect 3. The first time it was flawless but during my second play through I have all single player major DLCs installed.

I have Javik and Liara as my team mates and at the point you go to Ardat Yakshi monastery where you meet Samara (depends on ME2) - after two battles with banshees you take an elevator to the great hall.

In my case, however, the elevator keeps on going forever. The game doesn't hang but the elevator never stops going and if I choose any option from the menu (load, save, squad.. etc) then the game freezes. The only solution I then have is to resort to ctrl+alt+del.

I've restarted it several times tried different combinations of squadmates but the game always gets stuck on the elevator.

Any ideas on how to resolve this issue?

  • That's weird, but I doubt it's due to the DLC.
    – MBraedley
    Jan 22, 2013 at 17:53
  • Its DLC coz it was fine without that
    – Allahjane
    Jan 22, 2013 at 17:55
  • 2
    You don't know that for sure. Have you tried again without the DLC installed? Yes, it's odd that it's only happening now after installing the DLC, but correlation != causation.
    – MBraedley
    Jan 22, 2013 at 18:12

1 Answer 1


(if you haven't solves it yet) I tried the same thing. The only way I could solve it was loading an auto-save before you get to the Ardat Yaksi monastery. Its a minor mission, so you should be able to do it faily quickly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .