I was at the College of Winterhold and an ancient dragon appeared. I tried to fight him but he wouldn't land, so I summoned Odaviing on him. After a while I suddenly absorbed a dragon soul. What happened? The ancient dragon was still flying, so I figure it must have been Odaviing. Skyrim Wiki says he can't die, but now I'm doubting it.

I tried reloading and not summoning Odaviing this time, and I still absorbed a dragon soul. What's going on?

  • 5
    You need to use the "edit" button to add info to the question instead of adding more comments. Commented Jun 6, 2013 at 1:15
  • 4
    The whooshy light show you get when absorbing a dragon soul is directional - its source is the dragon's body. Try and get somewhere open so you can follow the light back to the dragon's body. I think the skeleton will be named if it is actually Odahviing. 3rd person camera may help.
    – Alex
    Commented Jun 6, 2013 at 12:32
  • In my experience you have to be quite close to a deceased dragon to absorb its soul. So if you absorbed a soul you should be able to see a skeleton nearby. Does this happen anywhere else in the game? If not, it's possible you killed a dragon near there before without absorbing its soul, and it's getting absorbed after there are no enemies nearby. The skeleton may or may not still be there. Just a guess here.
    – SMeznaric
    Commented Jun 6, 2013 at 14:25
  • I was in Solitude, just having a chat with Captain Aldis, when all of a sudden I had absorbed a soul out of nowhere, and I'm sure I've absorbed every soul of dragons I've slain.
    – user54010
    Commented Aug 20, 2013 at 7:17
  • Related: Can NPCs kill dragons? How to avoid it? Commented Jul 21, 2020 at 9:51

2 Answers 2


As iMAGEbox suggested in a comment, this can happen when someone else gets the kill-blow on a dragon in the same cell (which might actually be out of your line of sight, and happens pretty often in city attacks when a dragon isn't in the mood to land near you).

Another cause of this is killing a dragon while there's a big backlog of Papyrus script-processing. On a "potato" PC (or one that's better but running a huge pile of mods, or with other processes chewing up CPU cycles and RAM; or if you're playing in a VM on Mac or Linux), the game's script processing can get bogged down, and actions/reactions that depend on script completion can be deferred (or even fail if they have timers in them, or depend on Script A completing before Script B will do what it's supposed to).

A common symptom (aside from crashing every few minutes), and thus an easy test, is Soul Trap seeming to not work, until minutes later (sometimes quite a few minutes) and then you get a whole bunch of captured-soul sound effects and messages seemingly "out of nowhere" as the game catches up. This can also happen with a dragon kill and the specially scripted dragon-soul absorption routine. You can be half way across the map from where the kill actually happened when the script finally completes.

There can be other weird symptoms, like loss or distortion of sound effects, scripted NPC and quest actions not happening (this is the most serious consequence), stuttering of animation and sound, followers not following you through a cell change, ash piles appearing for no reason (especially ones that cause a CTD when you try to open them or even disable them with the Console), hotkeys added by mods not working when you press them, etc., etc. Basically, if the game is badly freaking out, script lag is likely the cause.

The short-term fix for this is to go somewhere safe with little happening or likely to happen, and just stand around idly, saving every minute or so (especially after evidence of some delayed script completing) until you don't get any more indications that scripts are still waiting for their turn, and the game does seem to be back to normal. If you want to be certain, have empty soul gems in inventory, then go soul-trap and kill the first bit of wildlife you encounter. If you capture the soul on the spot, then you're good to go. Also, if the game crashes during your wait-it-out phase and crashes again when you try to load your most recent save, try loading a much older save that was saved in a calm place like a shop, then load the most recent save.

Another quasi-fix is to just revert back to an earlier save that doesn't seem to be having this script-lag, then re-play through whatever you were doing before the problem started, but do it more slowly. Speed-running and doing anything script-intensive aren't a good combination.

Long-term, you need a higher-end PC, or the script lag will continue to happen periodically.


Perhaps it is because you had previously killed a dragon but never actually absorbed his soul and now that you have returned you are absorbing its soul from before. its also possible your game is glitched out

  • sometimes when others kill dragons you will absorb dragon souls. (this is glitch)
    – iMAGEbox
    Commented Aug 20, 2013 at 16:47
  • @iMAGEbox I believe that's actually how it's supposed to work. Commented Aug 21, 2013 at 5:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .