6

"Steam needs to be online to update please confirm your network connection and try again."

This started happening around a week ago. I looked it up, and I did the fix where you delete all the files but steamapps and Steam.exe, then restart your computer. I opened the file, open Steam, it updates and everything works. However, whenever I start up my computer again, it breaks and I have to do the fix.

Does anybody know how this is happening or how to fix it once and for all? Also, it is saved in a new Program Files directory (Program Files2) because the first Program Files directory never stopped asking for admin access (I am admin) and it would not allow me to do anything with that Program Files directory, and the broken one contains some Steam files in it. These files are in my separate storage drive (Z:). My system files are on my smaller (C:) drive.

I am running Windows 7 Ultimate.

  • If Steam is asking for Administrator prompts after being installed then you have serious system integrity problems. – Ramhound Sep 25 '13 at 12:48
  • @Ramhound Steam wasn't asking for administrator prompts, the folder was. Everything in the folder doesn't work, and I cannot move, rename or do anything to that program file. This was not the original program file in the directory, it was a new folder I created in my bigger (Z:) drive. – Crubleigh Sep 28 '13 at 5:23
  • @Crubleigh - Are you an Admin user on your PC? This sounds like some wierd permissions issue. – Robotnik Sep 30 '13 at 9:05
  • @Robotnik Yes I am admin. – Crubleigh Sep 30 '13 at 22:10
10

Sounds like a Race Condition. In short, Steam is starting up before your network card can obtain an IP address and establish an online connection, so Steam thinks you're not connected to the internet.

You're not the first person to have this problem! I've had a similar issue with my Laptop over Wifi and an old Modem/Router: Steam would give me this error on startup and I could never figure out why - until I got a new router. It turned out that the old router was struggling to output a Wifi signal, and therefore my laptop took longer to connect. The new router, having a more powerful Wifi antenna, didn't have this problem.

Here's what you can try:

Easiest Options:

  • Sit closer to your modem. (Obvious)
  • Connect to your modem via an Ethernet cord instead of Wifi.
  • Stop Steam from starting on startup, and instead start it manually once you have connection.

You can disable steam's auto startup from within Steam. Just got to

Steam Menu->Settings->Interface

and uncheck "Run Steam when my computer starts"
Auto Startup

A bit more effort

If you're absolutely hell-bent on having Steam start on startup, you could try:

  • Disable startup in steam, and then create a Scheduled Task that starts Steam with a delay
  • Update your network card drivers. Sometimes newer drivers have fixes for issues or improve performance.
  • Updating your modem's firmware. This is usually pretty advanced (especially for older models) and I don't recommend attempting it if you don't know what you're doing.

You could also buy a new modem, but they aren't cheap and may not solve your problem.

  • I am wired to my internet and it doesn't open on start up. I have to click the icon for it to open. I have mentioned that I can get it to fix (delete everything but steamapps and steam.exe and restart) but the next time I restart the computer its broken again. Also, as i previously stated, my program files are in a different directory (Z:) and that it broke so I had to make a second program files, however, there are still steam files in the broken file that could be messing it up. – Crubleigh Sep 28 '13 at 5:16
1

All I needed to do was open it from the file. The fix was pointless. Thanks anyways.

1

What fixed the issue for me was to make sure Internet Explorer could connect online. Apparently Steam uses the same Internet settings as IE, so if IE can't connect, nether can Steam.

In my experience, if IE can't connect but other programs can, the solution is usually to go in IE to Settings --> Connections --> LAN Settings --> check "Automatically detect settings"

Also, make sure you have any firewalls (including Windows firewall) and antiviruses disabled.


Some more possible solutions, found in this thread:

  1. Close all instances of Steam and make sure it isn't running.
  2. Open regedit.exe (by clicking the start-up bar/windows logo on the taskbar and typing in "regedit" in "Search Programs and Files")
  3. Navigate to HKEY_CURRENT_USER, then to Software, and then to Valve.
  4. Press on the "Steam" folder and to the right, registries should pop up.
  5. Right click "Offline" and click "Modify Binary Data".
  6. Set it to 0 (if it is at 1 under Data)

If that doesn't work (from the same thread):

I went into the control panel and opened Administrative Tools>Services. I right-clicked Steam Client Services and selected Properties. (For some reason my startup type was set to Manual) I set to Automatic and rebooted.

Another possible solution (again, same thread):

I went to the steam folder(c:\steam) and started the SteamTmp.exe, this started steam normally. Then I closed steam after checking the account was indeed online and started up steam normally again. That started the update.

Finally, as a last resort, from the Steam support article:

Please exit Steam and browse to your Steam installation folder(see below for default locations for a Steam installation - if you set a different installation directory, you will need to browse to it).

Delete all of the files in this folder except:
- \Steamapps\ folder
- Steam.exe (this file is listed as an application and features the black and white Steam logo)

Restart your computer.

Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.