3

I'm unable to run League of Legends on a guest account on my mac. Is there something I need to do to be able to do that? I've given all privileges I can give to the guest account in System Preferences.

This article is referring to a LoL folder on mac, https://support.leagueoflegends.com/entries/23240853-Mac-Administrator-Settings-and-File-Folder-Permissions , I don't know if they mean the app in the applications folder or something else but the app itself has permissions to read and write by everyone.

Any help about how to open and run League of Legends on a guest account on a mac would be greatly appreciated.

2
  • Can you give some more information on what kind of errors you get when attempting to run it?
    – Linuxmint
    Commented Dec 6, 2013 at 20:25
  • The logo appears like normally when running the game, but then it disappears and nothing is left. Neither in the dock or anywhere, but when I run it again, it tells me that another instance is already running but nothing is running that I could see outside of activity monitor. Commented Dec 7, 2013 at 15:04

4 Answers 4

2

I am assuming you are getting the same error that I got when trying to launch the LoL client as a different user than who installed it. The error is something along the lines of: "You do not have permission to launch League of Legends" or "This application cannot be opened".

I was able to get League to launch as any user logged into the computer. We are in a Windows domain environment where different users login to our lab iMacs.

You can do this by opening Terminal and running the following commands:

cd /Applications
sudo chmod -R 777 "League of Legends.app"

The above commands set file permissions using the CHMOD command on the "League of Legends.app" package and any files/folders below it (-R). The command allow everyone to read and write as well as open/execute the application (777).

Hope this helps!

1

This exact problem happens to me every once in awhile. I think its a Mac specific bug. Try doing a PRAM reset (restart your mac and hold ⌘ + ⌥ + P + R while it boots up).

Apple documentation on how to PRAM reset: http://support.apple.com/kb/ph4405

Then open LoL, and give it a good minute to start up, and make sure not to touch anything else on the computer until it gets past the logo. If you've waited a minute and nothing has happened after the logo showing, open it again when it tells you another instance is already running, press yes to cancel the old instance and open a new instance.

If this doesn't work I would recommend reinstalling the LoL client.

0

have to give permissions to the contents folder and all subfolders.

1
  • 2
    Could you say which permissions need to be set and what to set them to, also giving a general description of how to do it would really improve your answer :)
    – DBS
    Commented Dec 24, 2014 at 17:17
0

I had the same problem. There are two different ways to solve this: 1.Way: You go to Finder>Applications>LeagueofLegends>rightclick>Informations>Rights>everyone>No rights. then the computer will ask for the admin password, and thats it. 2.Way: You download LoL as a guest and, after starting this program, drag LoL to Applications and type in the admin password. But then the program will be deleted by logging out the guest account. You can choose ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .