5

I have the following command line options:

-noborder -novideo -threads 4 -high -w 1680 -h 1050

Yet, CS:GO keeps resetting my settings and set itself to fullscreen mode, which is bad when I switch out for a second between rounds, because due to DirectX9 used, it takes like 20 seconds to get back in. Unless I force the size via command line, the window also resets back 1440x990.

I need a no border fullscreen window, as indicated by my command line options. If I set it via the ingame options, it still resets after a few launches. But the command line should force it into those settings.

How can I fix this?

AMD 965 Phenom II Black Edition
AMD HD 7850 w/ Catalyst 13.12
2
  • 3
    you can create an autoexec.cfg into your css cfg folder with the same commands. the game will load them at startup every time. For dota2 this path would be C:\Program Files\Steam\SteamApps\common\dota 2 beta\dota\cfg so i guess for css it is C:\Program Files\Steam\SteamApps\common\counter strike source\css\cfg
    – Wandang
    Commented Dec 27, 2013 at 14:00
  • Make sure none of your cfg files are read-only. If they are, CS won't be able to overwrite your settings.
    – Decency
    Commented Dec 27, 2013 at 16:23

3 Answers 3

4

You should put those settings in the designed steam option for the game.

Right click on CS:GO -> properties. Select set launch options... and type your settings

Example: enter image description here

This will save your settings.

6
  • 1
    i thought he already did that. if he put it into the ingame console every time it would explain a lot.
    – Wandang
    Commented Dec 27, 2013 at 15:10
  • I remember that even changing your name in the game console would only last until the restart (or perhaps server change? )
    – Edeph
    Commented Dec 27, 2013 at 15:17
  • Already have this. Read my post again pls. Commented Dec 27, 2013 at 16:41
  • @Assylum you did not specify where do you have them, either on steam or on the file itself
    – Edeph
    Commented Dec 27, 2013 at 17:04
  • Maybe deleting clientregistry.blob and restarting steam is worth a shot :/
    – Edeph
    Commented Dec 27, 2013 at 17:10
3

Go into your CSGO/csgo/cfg/ and look for the config file and right click and enter it's properties. Make sure that the "Read Only" option is not selected.

If it is selected and the graphic options are designated in the config, then anytime you change them in the game, the game won't be able to write the new selections to the config because it is set to read only. That means every time you run the game again it is using the same old config settings to decide what options you want to use in the game.

Once you turn off Read Only and the game can change your config file as it sees fit, anytime you set your options and hit apply, the game will change that setting accordingly in your config.cfg file and that should fix the problem.

If this isn't the case and the config file is not set to Read Only then I am at a loss.

0

Try remove the command lines and try relaunch the game.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .