4

There's this old game, called Midtown Madness 2 (2000), that I love playing. It requires DirectX v7.0a. I also have a laptop. On this laptop, when I play the game on Windows 7, it works perfectly. In Windows 8, it lags everywhere, even in the menus.

I read somewhere that Microsoft dropped hardware acceleration support for DirectX 7.x in Windows 8. Is it possible to get the game working on Windows 8? I really don't like Windows 7 (long story), and this game is the only thing that's holding me back from upgrading.

1
  • 1
    Its not possible for Microsoft to "drop" support for hardware acceleration. That just isn't how DirectX works.
    – Ramhound
    Commented Apr 18, 2014 at 11:50

1 Answer 1

1

The possible solution is to disable Hyper-V (Windows 8 component) which is used for Microsoft virtual machines.

To disable Hyper-V go to Control Panel - Programs and Features - Turn Windows Components On or Off, then uncheck Hyper-V and click OK.

As other option I would try to turn On or Off V-Sync in the game video or in video driver settings, there is somewhat similar problem with Dead Space game on AMD videocards which fixes that way.

3
  • Hey - update. Tried that, but Hyper-V was already turned off.
    – NSDCars5
    Commented Apr 20, 2014 at 10:33
  • @NSDCars5 see update, but I guess that's my last possible guess what to try on that.
    – pabdulin
    Commented Apr 20, 2014 at 13:55
  • Thanks. Last possible guess didn't work, sadly. So it's either a VM now or a dual-boot.
    – NSDCars5
    Commented Apr 21, 2014 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .