2

I think I've broken Civilization V.

I am playing as Poland (red) and I attacked and annexed a Roman (purple) city and then within the same turn traded it back to Rome. Unfortunately the game seems to have got stuck waiting for me to choose production for a city that I no longer have:

enter image description here

Clicking "Choose Production" or the notification prompt does nothing. I have also tried saving and reloading the save and restarting the game but I'm just bought back to the same choice that I can't make.

Any ideas?

  • Have you tried the solution from gaming.stackexchange.com/a/8594/3936 ? – Private Pansy Jul 26 '14 at 12:03
  • I hadn't, but now I have! It doesn't work - still stuck at "Choose Production" :( – kalina Jul 26 '14 at 12:24
  • Can you right click the circle to make it go away? – Thorbjørn Ravn Andersen Jul 27 '14 at 0:03
  • Nope, right clicking on the notification icon does nothing, left clicking it doesn't even take you to the city in question – kalina Jul 27 '14 at 7:36
  • So this may not work for most people, but I had this issue with "Choose Research" being stuck. Simply hitting the Esc key on my keyboard resolved it. – Micah Henning Dec 30 '17 at 21:46
3

You have to reload a previous turn.

| improve this answer | |
  • 1
    IIRC, this is a known bug. Load a previous save (I set the options to autosave every turn) and make sure you choose production for the captured city before trading it back. – David Harkness Jul 29 '14 at 2:28
0

I know of two methods to fix this issue. Method 1 is through a mod, and method 2 is through an in-game fix:

  1. "IGE" or "IN GAME EDITOR": Just download the mod from Steam Workshop. Enable the mod, then you should see "IGE" on the "upper-right" part of your screen - click on "IGE" and then wait a little bit. You need to find the city with "buggy production" and then edit your production from your city. This resolves the issue most of the time.

  2. In-game workaround: Go to the city which is bugged, click on the city, then click "purchase", then on lower-left part of your screen, you have the "BACK" option and the "PRODUCE" option, you just need to click on "PRODUCE" and check what your city produces.

I also get this error because I have lot of mods, and several mods don't work together, or some mods don't work properly. If you want to test your mods fully, you must play from ancients time to the future. Then you will know if your mods work without any issues. I hope I helped you guys, these fixes helped me a lot. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.