1

I run league of legends on the highest graphics settings. Even when I play the game on low I still sit at 60 FPS. My resolution is 1920x1080.

  • My PC specs are a i3 3rd gen 3.3GHz Prossecor
  • NVIDIA GTX650 Ti Boost GPU

How can I increase my fps? I understand the eye can't see more then 60FPS but in teamfights when there is a lot of parcticle effects(Lux using Final Spark) I can drop to 15 which makes the game choppy. I do have Vertical Sync on.

  • I don't play LoL, but what would V-Sync effect if it was turned off? That seems to be a major frame killer in most games. Also, is there a way to turn down particle effects? If so, try doing both of those. – Shadow Z. Jan 29 '15 at 18:16
  • I'm not sure. As I don't really understand the full effect of it. I know it keeps the frames of the game together so prevents screen tear. – Charkz Jan 29 '15 at 18:21
  • @ShadowZ Vertical sync isn't a frame killer per se, it makes sure the frame sent to the monitor does get there while the monitor refresh. If it is turned off, it will send the frame regardless. It can help get a tad higher recorded fps but if its fps drop to 15, vertical sync off won't help much. – Jonathan Drapeau Jan 29 '15 at 18:22
  • 1
    No, it will work with all NVidia gpu. It worked well with my Palit gtx 460 and I'm sure it will work with my gtx 980 if I try it when at home tonight. With it, you'll be able to pinpoint where the bottleneck is : Cpu or Gpu. – Jonathan Drapeau Jan 29 '15 at 18:43
  • 1
    You should not be having a low frame rate with those specs, to be honest. I don't even drop down that low with my laptop, and it doesn't have dedicated graphics – eyeofthehawks Jan 29 '15 at 23:20
1

60 FPS is far faster then the eye can tell the difference, top motion animations (even today ) is only up to 40 or so fps May I suggest removing you shaders and if you do want higher fps to remove v-sync!

Thanks, hope this helps!

  • 2
    Where do you get that idea from that 60 FPS is faster than what the eye can see? This is just wrong! – phant0m Feb 1 '15 at 13:44
2

Shaders are the bane of every graphics card's existence. Turn down the shaders and anti-alising and you should see an improvement.

The 60 FPS is because it's locked to your screen's refresh when V-Sync is turned on. While it can prevent tearing, usually you can safely leave this turned off (I do and don't notice anything different). My money's on the anti-aliasing/shader settings.

0
  1. Turn all graphics down to the lowest.
  2. Set resolution to the lowest (800x600 I believe) - note this will not lower your field of view, just the resolution.
  3. Keep the game on fullscreen
  4. Turn OFF vsync
  5. Get rid of nonessential apps in the background

Your specs should give you pretty consistent 40+ FPS. If you do 1-4 and make sure 5 is done right you should be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.