3

When I hold my left mouse button down for a while to break blocks, and then I let it go, my avatar continues to break blocks. I can only stop it by left-clicking it once more. It is completely fine for all other games, it only does it for Minecraft.

How do I fix this problem?

  • 3
    Does this happen on any other games? – SirBenet Apr 2 '15 at 11:12
  • 3
    What are the specs of your computer? It might be Java is running slowly so you basically "queue" up clicks that run when you let go but are then interrupted when you click again. That's the first thing that comes to my mind anyways, given the behavior you've described. – Robert Wertz Apr 2 '15 at 13:44
  • I've had this problem using wireless mice. Never had this problem with wired mice. – Rainbolt Apr 3 '15 at 1:33
  • There is no way to fix this, as the new Minecraft launcher now no longer allows manually updating your LWJGL libraries. – Hugo Zink Jun 11 '15 at 8:52
1

If I'm not mistaken, your computer's OS or the driver's software for the mouse is set to have holding down for a bit of time to "lock" in the pressed position. Check your mouse driver's program and in your computer's control panel (the Mouse and Accessibility sections) to see if a setting is causing it. Using a laptop's touchpad is a common source of the issue as I have also witnessed it myself.

But if it is just like you said to the response of sniffylongnose, then I think your computer may be a bit overworked by Minecraft. Try to lower your graphics settings first and play without mods on a new single player world for a bit to see if it still happens. If that fixes it, or even if it doesn't, then your computer may not be strong enough to run the version of Minecraft you were using. Also remember that mods are a common source of demanding more processing power from your computer.

| improve this answer | |
1

I have had this problem too. What people don't realize is that Minecraft, despite having very basic-looking graphics, is surprisingly PC intense, especially if you're playing at higher graphic settings and with the widest view range you can get. For non-gaming-dedicated PCs, it can cause stuttering, chunk-loading problems, and problems like this one. If your game has performance issues beyond this one, this could be your problem*. Especially if you're noticing other performance problems along with it.

The easiest thing to do is to turn down your view rendering and graphics settings. This will reduce the resources Minecraft needs to use and help with performance. Using a Vanilla version will also help.

But if it doesn't, you may need to upgrade your computer. There are three things that might be causing an issue here - your Processor, your Video Card, and your RAM. Compare your system to the system requirements that I just got off of a quick google search and see if they're sufficient.

  • CPU: Intel Pentium D or AMD Athlon 64 (K8) 2.6 GHz.
  • RAM: 2GB.
  • GPU(Integrated): Intel HD Graphics or AMD (formerly ATI) Radeon HD Graphics with OpenGL 2.1.
  • GPU (Discrete): Nvidia GeForce 9600 GT or AMD Radeon HD 2400 with OpenGL 3.1.
  • HDD: At least 200MB for Game Core and Other Files.
  • Java 6 Release 45.

System Requirements for Minecraft

*Otherwise, it could be a mouse setting, since most games do not require you to hold a mouse button down for very long periods of time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.