I've been playing Minecraft for two years now and normally I know how to do everything correctly, but now I'm having a problem.

I'm in creative mode and left click simply won't break some blocks. It seems to affect random blocks, because I can break the grass next to it, but not that one. Eventually it will break after spamming the left click, but then it will break tons of other stuff and mess up what I'm building.

There might be something I never learned, or what, but what am I doing wrong?

  • I double-checked that I'm in creative mode and all of my controls are set correctly.
  • My mouse otherwise works fine outside of Minecraft.
  • All worlds I've tested are singleplayer so there is no spawn protection

I'm using Minecraft 1.8 and Windows 10.

  • If you have any mods installed, see whether the problem still occurs with a vanilla client. Try upgrading to 1.8.8, the latest non-snapshot version, and check if the problem still occurs. Also see if there are any invisible entities getting in the way of the blocks you are trying to break.
    – SirBenet
    Commented Sep 1, 2015 at 17:50
  • Try to inspect, if the block does not have some special NBT data, especially the ones what determine what you can break them with. If you wat to really get rid of them, install Forge version of WorldEdit and just delete them (or more complicated with commandblocks you can do the same) Commented Sep 3, 2015 at 10:15
  • Were you hitting with a sword? In creative, blocks can be broken with a sword in your hand.
    – Jim Jones
    Commented Oct 29, 2015 at 1:22
  • I mean can't be broken.
    – Jim Jones
    Commented Dec 25, 2015 at 17:41

6 Answers 6


There probably are some invisible entities, as that'd only affect some blocks (which they stand on or next to) and spamclicking will eventually make you go around it. Check in spectator mode (/gamemode 3) and then find the source (which probably are command blocks)

  • Alternatively, press F3+B to show hitboxes.
    – Kevin
    Commented Mar 23, 2021 at 21:39

My explanations are 3:

  1. You cant break stuff in creative while holding a sword
  2. It might be a problem because of the java: It might malfunction or what, so i reccomend you reinstalling Minecraft
  3. It might be a problem with your computer: When it is old, it has less than 2 MB of RAM (wich probably isnt it), its processor might be old and theese stuff.

I porbably didnt help you.


I used to have a similar problem with lag due to the RAM being capped at 2GB for minecraft, and a game like that really needs more, however there is a way around this. Open up a notepad and copy the following text into it.

javaw -Xmx8192m -Xms4096m -jar "C:\Users\YourUsername\Desktop\minecraft.exe"

Just make sure that you have the exe for minecraft on your desktop and substitute YourUsername for the username on your computer. This above allocates 8GB of RAM for minecraft, its a good rule of thumb to not go above half of what you have. I have 16 so I went 8. If you have anything lower you can use the following numbers in place of the numbers in front of the Xmx.

3GB: 3072
4GB: 4096
6GB: 6144

so for example if you were allocating 3 GB of RAM you would put the following into notepad.

javaw -Xmx3072m -Xms3072m -jar "C:\Users\YourUsername\Desktop\minecraft.exe"

After you have the correct text inside of notepad all you have to do is save it as a BAT file. To do this just save as and then where it says Save as type, change it to All Files. Then in file name type in something like, MinecraftStartRAM.bat and save the file. Finally all you have to do is double click on the BAT file you just saved and it will run minecraft for you allocating more RAM than what it is manually capped at.

Hopefully this solves your problem, but if not there are other ways to increase RAM that I will post links to below. If what I link below fails I would just try to reinstall.


  • 5
    -1. You do not have to create a separate batch file in order to run Minecraft with more RAM. This is directly configurable from the launcher under "edit profile". Secondly, -Xmx8192m -Xms4096m can be simplified to -Xmx8g -Xms4g, finally, there's no evidence that this will solve the OP's problem as well. Commented Aug 31, 2015 at 22:37
  • Which is why I gave him a link to the other way to do it as well as saying this may fix his problem Commented Aug 31, 2015 at 23:39
  • 4
    @JordanLeeBurnes This flat out does not work. "Minecraft.exe" is not a jar file, you'd need to at least run -jar game\launcher.jar, but even then, all you do is assign 8GB of RAM to the launcher, which does nothing for the amount of RAM the game itself receives, since that is another process altogether. And even if that somehow worked, it'd be a straight-up worse solution than just changing the JVM flags in the launcher directly.
    – MrLemon
    Commented Sep 1, 2015 at 12:40
  • 1
    It does work if you don't believe me try it yourself. This is what I did to fix my problem that was similar to the problem above. If I would have known the hostility that was headed my way for trying to help somebody I wouldn't have even posted trying to help anyone. However, i guess this community doesn't care about people trying to help, they just care about trying to berate each other when they think they are wrong. Excuse me I shouldn't' say the entire community so some of the community. Commented Sep 2, 2015 at 16:37

Sometimes all you need to do is go to Settings, Keyboard and Mouse, then scroll down and reset these to default settings. It worked for me!

  • Doubtful: if the right animation plays, there is nothing wrong with the controls.
    – Joachim
    Commented Mar 23, 2021 at 22:21

There is 2 explanations.

  1. You have a sword in your hand.
  2. You've reached bedrock.
  • @NBN-Alex In creative mode, wielding a sword prevents you from breaking blocks.
    – Skylinerw
    Commented Jul 5, 2016 at 0:51
  • You're correct, I've deleted my comment in response.
    – NBN-Alex
    Commented Jul 5, 2016 at 6:24
  • You can break bedrock in creative.
    – ALX
    Commented Aug 31, 2016 at 0:07
  • No, alx, you can't.
    – YoshiLikes
    Commented Sep 23, 2016 at 23:14
  • 1
    @YoshiLikes Yes you can. Go create a creative superflat and punch downwards. Commented Sep 29, 2016 at 18:42

It is because the game is lagging.

It is more suitable to download Minecraft PE on Windows 10. You can download it from the App Store. If you download Minecraft PC, it will lag very badly.

  • 2
    Comments are not for extended discussion; this conversation has been moved to chat.
    – Robotnik
    Commented Jun 21, 2016 at 12:43
  • Since the chat for comments here doesn't exist anymore, I'll make a comment here. You can't run minecraft PE on a PC, thats what minecraft Java Edition is for. If it is lag, there might be other factors. Since the OP says they're building things, there might be too many entities in the chunks nearby. "If you download Minecraft PC, it will lag very badly" ? Ask the huge majority of PC players if their minecraft lags all the time for no reason. Only a few will say yes.
    – Cyanite17
    Commented Jan 14, 2021 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .