3

When I fire up KSP, the launcher will say "Looking for updates" rather than play or options, and the background will be a big red question mark rather than the Kerbal X Space craft. It worked just fine until now and I have had this game for a while. I am connected top the internet.

2
  • 4
    Today KSP has been updated to the 1.0, so things may be wonky. The website itself at the moment is unreachable because of a server migration. – Kappei Apr 27 '15 at 13:20
  • Mine has been down for about 18 hours now, as have been the related web sites. – James Jenkins Apr 27 '15 at 16:45
1

It looks like you're experiencing and issue with the update. Remove any mods that you've added, be sure to leave the "Squad" directory in the "Gamedata" folder.

If that doesn't work you might want to reinstall the game.

1
  • 1
    I just wanted to add onto your answer, since you are right that he should remove any mods. It sounds like the problem is with one or more of his mods, because i've never seen the vanilla game try to update the game outside of steam (I.E. it's own launcher, in-game, etc.). Mods do however, try to update itself when the game is loading the files, but unless there's something obvious on the screen, the only option is to remove all mods or one at a time. – dakre18 Nov 20 '15 at 19:14
1

I had just purchased KSP a couple weeks before the update to 1.0. After a couple of days of the checking for update issue that you describe, I uninstalled KSP and deleted all related files.

I followed the down load instructions at the wiki and everything is now working fine.

-2

I had the same problem, I just deleted the whole thing and redownloaded it. You can try keeping your savefiles if you want, but I didn't care about mine as it's been ages since I played last.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.