0

On Steam, I uninstalled TF2. A while later, I reinstalled it. However, when it finished, it keeps validating the game over and over again. I've tried many things; reinstalling it countless times, moving files, etc. and what I've noticed is that it does not do anything to my files when it installs (at least, to my knowledge) but it isn't detecting the files and still trying to reinstall. Is there any way to fix this?

  • I assume this is happening in a Windows PC? When you reinstall TF2, does the Windows UAC popup show up? Since the files are not getting touched, I have to assume it might be a permission issue with the Steam client when trying to update the folders. You can test this out by running Steam as an administrator (completely not suggested normally) by holding SHIFT and right clicking on the steam icon. – NBN-Alex Jun 5 '15 at 0:35
  • Tried running Steam as an administrator, and to no avail. It works exactly the same as always. Didn't know if this would be useful at the start; it says it's downloaded 6.8 gb but in the Steam properties it only says 36 mb. I also just found out that TF2 is the only game I'm having this problem with. – akir_ Jun 5 '15 at 10:56
1

This could be an issue with Steams permissions to access the folder, if you have it installed in a different location or have a windows link junction. But it can also be a mod you may have installed in the past.

Try fully deleting the folder for TF2

C:\Steam\SteamApps\common\Team Fortress 2\

Then install it through steam and see if it works. When steam uninstalls a game it leaves behind config files, settings, and certain types of mods.

Before deleting, you should backup the game to save your configs and such to reuse later.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.