2

I've made three resource packs from the same template. They are all in my resource packs folder, but only one shows up in the menu. One of the two that don't show up used to show up, the other I just completed and I have never been able to test. After scouring the internet for about an hour and try every fix i could find, nothing has changed. So I decided to ask my own question. And no it's not zipped, but I run Sphax unzipped just fine, and my other resource packs work fine unzipped, so no, that won't help.

3

4 Answers 4

4

I'm here because I was having a very similar problem. I've just managed to solve it, and I figured, even if this question is a bit old by now, maybe something I did will be helpful for you, or for whomever comes along next.

I was trying to mix and match some textures from my favorite resource packs. I found that, when I tried to modify the pack description in pack.mcmeta (the text after description:), even the tiniest bit - like deleting a character and then putting it back - Minecraft was immediately unable to recognize my resource pack. Here's what I did:

  • I went to TextEdit > Preferences > Format, then selected Plain text rather than Rich text.
  • While I was there, just for good measure, unchecked Add '.txt' extension to plain text files in the Open and Save options.
  • And this took me forever to notice, but whenever I altered the pack description, the quotation marks around it auto-corrected to their slanted versions. Apparently, it's super important that they remain regular vertical quotation marks. When I finished editing my description, I just copied and pasted in vertical quotes before saving the file.

Some other info: I'm on OS-X Sierra, using Minecraft 1.10, pack format 2

0

It doesn't make a difference if they are Zipped or not. When you open the Zipped/unzipped folder you should see another folder named aspects. If you don't see that I think I found you're problem... You Just move the Folder that contains the aspects folder to your resourcepacks folder.

0

Check to make sure the folder structure isn't:
RPN/RPN/assets/...
instead of
RPN/assets/...
Note: RPN stands for Resource Pack Name.

When zipping on a mac, select the assets folder and pack.mcmeta to compress, not the folder containing those files

Also check to make sure your resource packs contain a pack.mcmeta file

1
  • I tried that and it did not work also, for me sphax is just rpn/assets. Commented Jul 18, 2015 at 20:09
0

Do your resource packs contain a pack.mcmeta file? This is a necessary file in resource packs which makes them able to be detected by Minecraft.

1
  • This isn't really answering the question... Commented Oct 8, 2016 at 1:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .