1

I'm currently playing Pokémon Red on the 3DS virtual console and was excited to find that the old glitches were still in tact.

Long Range Trainer Glitch Guide

When I made use of the Long Range Trainer glitch on my original Red cartridge, I used Abra's teleport in Cerulean, but I never tried it anywhere else. I know there is another potential Mew using a north-facing Gambler on route 8, but when I tried this using teleport, when I return to the area, no other trainers will start a battle with me, and I have to reset.

The guide says to use fly, but also says teleport can be used to acquire Mew at the earliest point in the game, which I can verify. I don't know why it wouldn't be a valid way to initiate the glitch in any other area.

  • Ah, my fault for not reading what the purpose of the "glitch" tag was. Is there no appropriate tag for such a topic? – Taylor Lopez Mar 27 '16 at 4:20
  • 1
    [cheats] covers cheat codes, gamesharks/ARs as well as glitches/exploits, because a 99% of the user base doesn't know (or care) about the difference between them :-) – Robotnik Mar 27 '16 at 15:51
2

Yes, you can use any move that will take you away from the currently planned fight. Dig or an escape rope would also work as well. From the article you linked.

Any method of 'escape' from the Long-Range Trainer may be used, including Teleport and both Dig and the Escape Rope if the Trainer is in a cave area.

This is because the key to the glitch is actually triggering the Long Range Trainer with the ! above their head to initiate a battle, but not letting it start. Any method from the menu by which you can do that should work.

Of note, it may be difficult to use teleport or dig over fly mostly because of the nature of these moves. You don't get to control where you end up quite as easily as you do with fly so it would require a more planning and setup to get it to work than it would otherwise.

  • I'm fairly certain other trainers can only be battled on the route where you performed the glitch as well. At the very least, I've run into the same problem as the OP in that trainers won't activate a battle (and it always happens on routes different to the glitch trainer) – Robotnik Mar 27 '16 at 15:55
  • @Robotnik Yes, you don't actually return to that route until after you've battled another trainer somewhere else. That route is glitched until you trigger another LRT in a different area. And the trainer has to take at least 1 step otherwise you will soft-lock the game – LoveAndCoding Mar 27 '16 at 16:19
  • Yeah that was it. It's been so long lol – Robotnik Mar 27 '16 at 16:20
  • A-ha! That's the key then. I think I've been trying to battle trainers in the same area, so no new battles will start. That makes sense. Thank you! – Taylor Lopez Mar 27 '16 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.