7

Hardware and Software used:

  • iMac 27" (late 2012) with NVIDIA GTX 680MX (I know, not ideal for gaming), Windows 10, Steam, Skyrim, NVIDIA GeForce Experience and GameStream enabled, ScpToolkit (a program that connects PlayStation Gamepads as if they were XBOX).

  • A Raspberry Pi 2 with OSMC OS running Moonlight Embedded.

  • Normal mice and keyboards.

  • Sony Dualshock 3 and 4.

I have already set everything up so when I start Moonlight, and I connect to my PC with Steam as "game", the screen gets displayed onto the TV my Pi is attached to. The only problem is that OSMC (the operating system used by my Raspberry Pi) does not support Dualshock gamepads: when I connect them, all the axis are wrong and many keys do not work. My particular configuration does not allow me to set up custom keymaps for Moonlight, so (since the TV is very close to the Computer), I tried to use the Dualshock 4 via Bluetooth directly to the computer. Whenever I start Skyrim directly from the PC, the gamepad works like a charm, but when I connect with GameStream, the Gamepad connected directly to the PC stays on (and pressing Home button Windows 10 asks me if what's running is a game), but Steam and Skyrim (I expect all games to be so) refuse to respond to the controls of my Dualshock. If I connect it to the Raspberry Pi instead, the keymaps are wrong, but the game responds to the (wrong) controls. Weird fact is that the USB keyboard and mouse (connected directly to the PC) are working!

What I suspect is that GameStream is overriding my (simulated) XBOX controllers with their (simulated) remote XBOX controller. How do I disable the input from GameStream so I can control the games from the PC itself?

  • Are you streaming to your TV? If your PC is close to TV, why not just use an HDMI cable to connect the TV as a screen for the PC and avoid all the problems you're having here? Or do iMacs not have hdmi outputs..? – Elise Oct 16 '16 at 12:38
  • When you ask a question... you get no answers, an upvote appears... it's a clear sign that your SE question is going to stay unanswered forever. Let's make a bit of haste... – Manchineel Oct 19 '16 at 15:39
  • Just for clarity, when you say "the PC," you're talking about your Mac, right? And you are trying to connect your gamepad to the Mac, but the Pi is what is doing the streaming? Also, please tag me in a comment if you reply, otherwise I won't get notified. I just happened to see the previous one when I checked back on this question. – Vemonus Oct 19 '16 at 16:03
  • @Vemonus The PC is my Mac, yeah. I just call it PC because I often use it with Windows and Ubuntu. And the Raspberry Pi is the client for Nvidia GameShare – Manchineel Oct 19 '16 at 17:43
  • 1
    @Vemonus Thank you very much. It's so true that SE is the best community on the WWW – Manchineel Oct 19 '16 at 17:45
4
+50

Based on what you've described, I think this post has a solution.

Using a wired/wireless controller connected to the GFE PC instead of the streaming device

Normally, Moonlight sends controller input from the streaming client which gets sent to the game by GFE. If you want to connect a controller to your PC instead of the streaming device, GFE can cause some problems because the emulated controller still appears to games as controller 1. Luckily there is a workaround for this. You'll need to rename the DLL that Nvidia is using to send controller input so it won't be used anymore. On 32-bit and 64-bit Windows, rename rxinput.dll to rxinput.dll.old on in C:\Program Files\NVIDIA Corporation\NvStreamSrv. On 64-bit versions, there's another copy of the DLL in C:\Program Files (x86)\NVIDIA Corporation\NvStreamSrv which you'll want to rename. You may have to do the renaming again if GFE does an update, but it should allow you to use your controller normally on games that only support 1 controller.

(I bolded the instructional portion of the quote for ease of access)

It will also be necessary to rename rxgamepadinput.dll and rxnvgamepad.dll, both located in the aforementioned directories.

  • It seems great. Let me finish to reinstall Windows which got a little corrupted after my latest experiment (lol) and I'll try this. – Manchineel Oct 19 '16 at 19:07
  • @alex2003super awesome, glad to hear it could help – Vemonus Oct 19 '16 at 19:10
  • Oops... I did not notice I was posting a question. I was in a hurry with the phone app, anyways, now Steam does not start from GS, only the GFE logo instead of my wallpaper and loading sign instead of my cursor, that I can move from both the PC and the Client – Manchineel Oct 20 '16 at 12:35
  • I was just saying that the desktop wallpaper turned into NVDIA logo, the Windows cursor started the loading (blue spinning circle) animation but no Steam was getting displayed. I fixed it by installing NVIDIA Game Ready driver and rebooting. Also, I had to remove two other components to disable remote gamepad input. Lemme update the answer. – Manchineel Oct 20 '16 at 19:35
  • @alex2003super with the update you added, does this answer work? I'm confused – Vemonus Oct 20 '16 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.