11

In Civilization (edit: pre any patches) 6 I want to skip the opportunity to City Range Attack a unit because I want to do it next turn with a unit.

Is this possible? In Civ 5 you could simply right click on the attack icon (this doesn't work). Can find nothing online.

thx.

Edit - screenshot of the situation enter image description here

  • You never HAVE to make a city attack. What are you asking? – Dallium Nov 19 '16 at 1:18
  • 1
    @niico asking people to un down vote won't do anything. Also, votes are locked in after 5 minutes. – Vemonus Nov 19 '16 at 1:54
  • 1
    There's no reason to downvote this question, it's worth making that point. – niico Nov 19 '16 at 2:03
  • 1
    Yes it does - it is doing it to me right now. (I'm on the Mac for what that is worth - but I don't see why that owuld make a difference). – niico Nov 19 '16 at 4:21
  • 1
    @Dallium sometimes it does... and yes sometimes it forces you to click it. – CodeCamper Nov 20 '16 at 18:14
6

In later patches you appear to be able to just right click on todo items to pass on them (as in civ v).

|improve this answer|||||
  • To expand on this a bit, there is a small City Ranged Attack notification circle on the right-hand edge of the screen. That's what you right-click. – hughes Mar 9 '19 at 20:05
1

I had the same problem. I solved it by disabling the Auto End Turn. The city attack symbol still appears on the map but the symbol in the bottom right corner of the screen is the End Turn Arrow instead of the City Attack symbol.

|improve this answer|||||
1

You can go onto "options" in the top right corner, and then go to "city ranged attack turn blocking" and disable that.

|improve this answer|||||
0

Patch [1.0.0.167]

My situation was a hidden Nuclear submarine was adjacent to my encampment. One of my naval units revealed the hidden sub.

The message and exclamation mark symbol on the end turn control was forcing me to make my encampment ranged strike. But there was no red dot on the encampment to perform the action.

I believe this is a bug and the only way I could get to the next turn was to save and reload.

|improve this answer|||||
  • did you try right clicking on the unit to skip the attack? – niico Sep 4 '17 at 9:10
  • I tried clicking everywhere thinking it may trigger the encampment attack. Same for right click. I remember trying every mouse combination including clicking on the encampment and then clicking on the sub as if it would trigger the encampment attack – Valamas Sep 5 '17 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.