I have the open beta of For Honor, but when I play it it doesnt run the smoothest, and in the games options it says that its using the intel graphics card, while I have a Nvidia GT 750M installed too.

I've set the application to use the Nvidia through the control panel, and the 3D settings but it doesn't make a difference, the game still is kinda slow and says its using the Intel graphics.

Any idea whats happening?

Double-check your connections in the back of your PC. I've had this kind of thing happen in other games when I accidentally plugged my HDMI cable into the wrong socket.

My PC has a graphics card with an HDMI socket or two, but it also has a separate HDMI socket specifically for the Intel card. If I accidentally plug my HDMI cable into that separate Intel socket, the graphics for that monitor will always go only through the Intel card.

There is a method that worked for some people which is to Find the exe in the install folder, right click, and choose to run with the nvidia gpu I think it might work for you and If not try using the NVidia control panel

  • Which people did this work for? Like your other answers: they'd be a lot better if you could provide the sources from which you found the information. – Robotnik Feb 14 '17 at 2:34
  • sorry I didn't pay much attention – arslan babur Feb 14 '17 at 13:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.