1

So I created a forge server on my Personal PC and tested a connection with another computer on the LAN, it worked. Now i would like to allow outside access to the public for my friends.

I've done everything on the list that I could find but it still doesn't work, every time i try to connect I get the "Connection Refused error". Here are the things I have done:

1.) Fowared port 25565 on my router and mapped it the fixed IP my PC has.

2.) Set firewall rules to allow TCP and UDP port 25565 for both incomming and outgoing.

3.) Disabled Firewall completely (still no dice).

Note that i check my port from the outside using this online tool, and according to it 25565 is open. Also I don't have a antivirus that assumes control over the firewall.

  • I think you have to run it as a server not open it to LAN.. LAN might only accept LAN connections not Internet connections. Or make sure you are giving people your external IP address.. – James Jul 20 '17 at 22:22
  • I found this page which may explain your problem. Forge servers require the client to be the same game version with the same mods. – IronAnvil Jul 21 '17 at 4:30
  • Yeah no I gave them my public ip. Also, the client version is the same as the server, I used the same forge installer for both client and server and just selected client / server respectively when I installed. – Marnus Steyn Jul 21 '17 at 6:35
  • did you also port forward 25566? – MadMrCrazy Jul 21 '17 at 14:47
  • 1) Do you have multiple routers? Use a util for this one, and if so, you may want to set one of them on NAT mode like I did. 2) Does it show the connection being refused in the console? 3) Does it work for a regular server? – RookieTEC9 Jul 22 '17 at 10:08
1

Forge can be quite finicky sometimes, so to make it work you need to make sure the mods and forge version you are using matches your friends. Previously when I used forge servers before, my friends downloaded the same mod with a slight version change and that was enough to stop everything from working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.