8

Rainbow Six Siege stutters every few seconds or so. My PC is definitely more than capable to run the game well but I have no idea why it still stutters. It has happened to me in other games, like CSGO. I have run virus scans and updated Windows.

In this context, stuttering is when R6S freezes for about 0.5-1 second every 5-10 seconds.

I have tried this guide to fix my issue, including some of the comments' suggestions, like uninstalling Microsoft C++ 2010 Redistributable Package. Even running Anti-Virus and Anti-Malware software does not help.

My PC's specs are as follows:

Processor: Intel i7-7700k (4.4 GHz on an EVO 212 Air Cooler)

Graphics Card: EVGA GeForce GTX 1080 FTW ACX 3.0

RAM: Corsair Vegeance LPX - 16 GB/3200 MHz

Storage: 120 GB SSD + 5 TB Western Digital Professional at 7200 RPM

Monitor: ViewSonic XG2700 - 4K @ 60 Hz with a 5ms Delay (3840x2160)

Power Supply: Corsair CX850M (850 Watts)

Operating System: Windows 10 Home Premium 64-Bit

  • Good question. I had exactly the same problem ten years ago with Bioshock and I never did find a solution. Some people claimed the problem was caused by the game switching between cores on a multi-core CPU. – Bobulous Sep 23 '17 at 18:58
  • 1
    If you have W10 Game Booster turned on, try to turn it off? Maybe that works. – BadAtPHP Sep 23 '17 at 18:59
  • Have you recently updated your drivers, especially graphics drivers? I know I hadn't played in a while and recently went back and was given a notification that my graphics driver needed to updated for the newest content. – n_plum Sep 23 '17 at 23:25
  • @n_palum Tried that, but unfortunately, it didn't work. – Camouflaged Cow Sep 24 '17 at 11:22
  • Is VSync disabled? If not, try that. I've noticed improvements in random games by turning VSync off. – Kaizerwolf Sep 25 '17 at 12:46
2
+150

In my experience, the most common cause of this (provided the hardware is beefy enough to support the game, which seems to be the case here) is the defragmentation of the drives. I know modern Windows OS versions claim to do this automatically, but there needs to be sufficient free space on the disk in order for this to occur. Personally I find that it's not good enough, and often perform the task manually every few months or so, especially after installing and deleting large files (usually games in my case, some with several thousand files or more).

One other thing to try is to look at your paging (swap) space. Contrary to what some think, the swap space can be too large, or if the paging file is on a heavily fragmented drive, that can cause issues too (unless it was there when the disk was formatted, it shouldn't be fragmented at all).

Hope that helps.

  • How do I check the page file? I did an entire optimization and left about 800 GB free so it is not the hard drive. – Camouflaged Cow Sep 29 '17 at 2:51
  • Right click on start button, select Control Panel. Then System and Security then System. Then on the left panel, Advanced System Settings. Then under the Performance frame, click Settings, then select the Advanced tab. It will show virtual memory (same thing.) I've always used the rule of 1-2x the physical memory for swap/virtual memory, but your mileage may vary. – Tim S. Sep 29 '17 at 4:26
  • My page file is default at 9216 MB, but I have 16 GB of RAM. Should I change it to 16384 MB? – Camouflaged Cow Sep 30 '17 at 22:47
  • I would -- but I don't know if it would completely mitigate your performance issues. It should improve it somewhat though. – Tim S. Oct 1 '17 at 1:19
  • Apparently my hard drive didn't have any allocated page file size, so I set it to system managed, which brought it up to12160 MB. – Camouflaged Cow Oct 1 '17 at 15:41
0

I had a similar issue when I initially got the game.

Could I ask, do you have a similar issue when playing Fallout 4? I had this problem with Rainbow Six Siege and Fallout 4, drove me nuts.

I did a lot of tinkering, I spent around 5 days tweaking, modifying, resetting etc, nothing worked.

I remember I left it for about 6 or so months and magically it was working. In this period I did the following things:

Did a completely fresh install of my Graphics card drivers, including removing any Nvidia software from my PC.Then did a fresh install of everything, specifically getting all of my software from the NVidia site instead of the discs provided. I would recommend getting the installers beforehand.

Re-installed Steam: Took out my D drive with all my games onto be triple sure I didn't delete them.

I would recommend trying the above, I can remember the frustration, hopefully, you find a solution, do remember to take a break.

-1

Since it's only one game that's causing the issue, and you've most likely installed it on the HDD, try reinstalling on your SSD and see if that improves things. With the machine specs you have,that 5Tb HDD is holding you back. I'd recommend investing in an SSD dedicated to games. You can pick up a SanDisk 240Gb SSD for less than £80 in the UK ($90 in the US) on Amazon.

-1

interesting. and a decent rig too. swap file recommendation is 1.5 ram size. yes 24g is big and debatable but thats what i have with no problems. defrag properly and regularly of course. not the SSD. if it's only one or two games that are giving you trouble it's probably the games themselves. some games just won't play nice. tweak the graphics a little. you probably won't notice visually. or try the old favorite turn off your AV software. or is something big and hungry running in the background?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.