4

In Age of Empires: Rise of Rome, when you create a server, it provides you with the IP address you have to set in the Internet Protocol Version 4 (TCP/IPv4) of the Wireless Network Connection Properties, by selecting the option 'Use the following IP address'.

The IP address that I have set it is not showing up in Age of Empires: Rise of Rome - instead, it shows two IP addresses, as can be seen in the image below:

enter image description here

The above image shows Age of Empires: Rise of Rome installed on Windows 10.
I have also tried these settings in Windows 7, where the game was able to successfully connect to the IP address which I had set in the Wireless Network Connection Properties.

The IP address settings which I used:

enter image description here

The Windows 7 installation of Age of Empires: Rise of Rome, which was able to successfully connect:

enter image description here

But in Windows 10 it is showing those two different IP addresses, instead of the IP address which I have configured for it.

Does anyone know why this happens, or how I can adjust the settings so I can start hosting games?

  • I edited your question - if you don't agree with any change, feel free to adjust them. I presumed you want to host local multiplayer games. – Joachim May 26 at 10:00
  • Yes I want to host age of empire locally any suggestions for the solution? – Haziq May 26 at 13:58
2

Since Rise of Rome connects successfully with Windows 7 and this latter is obviously connected through local ip 192.168.0.11 which is the ip for "Wireless network connection"

Now the The reason for you are seeing two local ips in Windows 10 is that you have two network connections enabled. And rise of rome is picking two local ips from two network connections but most definitely only using the first ip on that list.

Only keep "Wireless network connection" which is your Wifi internet But disable the rest.

disable network connections

Windows 10 & Windows Defender

Windows 10 comes with an integrated Antivirus(Windows Defender) + Windows Firewall. So you must add your game exe file to both Windows Defender + Windows Firewall. Doing so ensures that the game won't be interrupted or slowed down or blocked.

An Observation

The screenshot you took for windows 7 static ip shows a different local ip format 192.168.0.X which means your gateway or router address should be 192.168.0.1. Your local PC ip (based on your image) is 192.168.0.11.

So make sure your windows 10 local ip address is of the same format too. And do not leave the Default Gateway: empty. Fill it with 192.168.0.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.