8

Maybe this question fits better into https://apple.stackexchange.com/, but it will probably help more people in this area:

I have iOS 13 and the newest version of Pokemon Go installed and when I try to turn on Adventure Sync in Pokemon Go's settings, following popup window appears:

pokemon go adv sync pop up window

The screenshot is in German, but it says following:

Missing Adventure Sync permissions

Pokémon GO needs your location in order to find nearby Pokémon and PokéStops. Please adapt your settings and activate location services.

  1. Open Health App.
  2. Select "sources".
  3. Select "Pokémon GO".
  4. Select "Turn on every category".

(Just a corresponding translation, not certain of the correct English wording)

In the iOS settings I granted Pokémon GO any permission I am able to. However, in the Health App I can't find any entry for Pokémon GO at all ...

What do I have to do to turn on Adventure Sync successfully on iOS 13+?

8

I have iOS 13 but I did set this up before I updated my phone so I'm not sure if I was just grandfathered in. Try the following in the Health app:

  1. Hit the icon in the top right corner to go to your account.
  2. Under the privacy section hit apps.
  3. You should see Pokemon GO there.

Picture of Apps in Health application on iOS 13

Then just allow access to everything as suggested in the instructions from Pokemon GO.

EDIT:

Per the conversation in the comments, follow the directions in this Reddit thread https://www.reddit.com/r/pokemongo/comments/c58uo5/adventure_sync_on_ios_13_possible/ to fix this issue in iOS13 if the above did not work:

  1. Turn off automatic app download under General in the watch app (if you have an apple watch).
  2. Reinstall Pokemon GO.
  • I assumed Pokemon GO to be in this section. However, for me it doesn't appear there. – h0ch5tr4355 Oct 7 at 15:12
  • 1
    It could be an issue on either side to be honest. I'd wait for a Pokemon GO update and try again since we all know Apple does not like to patch their apps in a timely manner! – Cloudzzz Oct 7 at 15:16
  • True. And going back to iOS 12 is not possible afaik. At least not on an easy way. I setup Pokemon GO right after I have installed the iOS update. Bad luck probably :D – h0ch5tr4355 Oct 7 at 15:17
  • You should also check in the iOS settings app since there are also app allowance settings under Settings -> Health -> Data Access & Devices. Hopefully that will help. – Cloudzzz Oct 7 at 15:21
  • 1
    It worked !!! Thank you. This really did the job. – h0ch5tr4355 Oct 7 at 16:05
7

If Pokémon Go is not listed under the Health options in your settings, you have a couple of different options to try based on a few sources:

  1. Niantic Support suggests to check your Motion & Fitness configuration within your Privacy settings.

    It might be possible that Fitness Tracking is not permitted on your device, hence you're unable to view Pokémon GO in the Apple Health app. Try enabling it from the Motion & Fitness option under 'Privacy Settings'.

  2. If the the problem persists after checking your privacy settings, the reddit community suggests un-installing and re-installing Pokémon Go. Many of the users there confirm this fixed this issue for them.

If neither of the above worked, then I suggest submitting a support ticket to Niantic

  • 1. probably relates to Android and not iOS. 2. I have seen this post, too. But it didn't work for me. I think that it has to do with the new Health Update from iOS 13, but couldn't find any statement, that proves this assumption – h0ch5tr4355 Oct 7 at 12:35
  • 1
    @h0ch5tr4355 For the twitter post, the user who posted the question on the support page stated they were using iPhone SE. I have iOS13 as well and I haven't had any problems with Adventure Sync – Wondercricket Oct 7 at 12:39
  • Ok eventually managed to find those settings, but still no Pokemon GO is listed there. Did you have set it up with iOS 12 already? – h0ch5tr4355 Oct 7 at 13:34
  • @h0ch5tr4355 Android doesn't have an "Apple Health" app, only iOS devices do. – Allison C Oct 9 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.