I want to play Half Life 1 on a borderless window. If I enable "Run in a window" on the Video Options, the taskbar is still visible for some reason.

How can I play Half Life 1 (or any GoldSrc game) in a borderless window?

enter image description here

  • does "auto hide taskbar" option solve your problem? – arghtype Jan 21 at 19:58
  • 2
    I need the taskbar visible for my second monitor. Other games just disable the taskbar for the primary monitor and leave the other monitors as-is. – Lemon Jan 21 at 20:00
  • 1
    "Other games just disable the taskbar" -- they generally don't. Windows figures out when it should get out of the way; see devblogs.microsoft.com/oldnewthing/20050505-04/?p=35703. Running in a bordered window breaks this. – Roger Lipscombe Jan 22 at 10:25
  • "Running in a bordered window breaks this" actually no, as long as the total size of the window matches the current monitor resolution (example: Grand Theft Auto V). – Lemon Jan 22 at 22:07

You can set the game to run in a borderless window through Steam:

Right-click the game in your library, go to 'Properties...', select 'Set Launch Options', type in -windowed -noborder, and click 'OK'. Twice.

Steam Set Launch Options to -windowed -borderless

This should logically work for all Goldsource games.

|improve this answer|||||
  • 1
    Yep, it also works with the other GoldSrc Half Life games and Counter-Strike. – Lemon Jan 21 at 22:15

For all games that can run in windowed mode (including Half Life 1), you can also consider using fullscreenizer, an open source tool that forces a chosen window to become fullscreen borderless.

This is especially useful for games that do support windowed mode but don't support fullscreen borderless. But as Joachim pointed out, this specific game does. I personally use it for certain indie titles.

|improve this answer|||||
  • My understanding is that Windows 10 does this automatically now (meaning there's actually no reason to explicitly run the game in borderless fullscreen, because it already is). See here – BlueRaja - Danny Pflughoeft Jan 22 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.