2

I recently helped my friend install Minecraft Java Edition on his Chromebook using the Google supported linux beta (which is Linux Debian).

He can make a singleplayer world, and it works just fine. He can also start a LAN game which I am able to join.

However, he cannot connect to any Minecraft servers. I tried making my own server and a client using UDP Sockets in Java (this is only to provide context) and my friend couldn't join my games (via LAN), but I could join his.

Same thing occurs in Minecraft. I can join his LAN worlds, but he cannot join any servers/worlds.

He is using the default JDK, which is Open-JDK 11, if that helps.

I have tried making him uninstall java, I have tried making him install java 8 with sudo apt install openjdk-8-jdk instead of the default-jdk, but it said "Unable to open package". I'm not even sure if this is java's fault. It can possibly be his firewall.

To provide more context, he is using Optifine, and he has tried both Minecraft 1.8.9 and 1.14.4 without success.

When he joins, Minecraft shows this error message:

Internal Execption: java.lang.RuntimeExecption: Unable to access address of buffer

What is the problem, and how can I fix this?

4
  • What are the errors in the game log when he tries to connect to the server? May 5, 2020 at 4:42
  • JDK is for developing apps not playing them, but JRE should work fine. Are you sure that Java has private and public network permissions from the firewall?
    – Ben
    May 5, 2020 at 8:54
  • @Ben How would I do such a thing on a linux machine (Debian)?
    – GamerM
    May 5, 2020 at 11:44
  • @GamerM ah this was the reason I didn't want to answer the question, I don't know. I would try google's support site since this is a chromebook and linux firewalls are specified by the OEM
    – Ben
    May 5, 2020 at 12:23

1 Answer 1

1

According to this: https://hypixel.net/threads/solved-connecting-to-hypixel-from-1-8-9-is-not-working.1977642/, you need to change the java executable to make sure that the correct java version is being used.

This is how you do this in the latest Minecraft Launcher:

  1. Press the button at the top labelled "Installations"
  2. Go on to the "Latest Release" installation
  3. Press "MORE OPTIONS"
  4. In the box titled "JAVA EXECUTABLE" enter this path:

/usr/lib/jvm/java-8-openjdk-amd64/bin/java

If that doesn't work and he is using UFW firewall try seeing if it works after running: sudo ufw disable (this command might not exist)

3
  • 'sudo ufw disable' gives command not found, I am trying the Java Executable thing right now.
    – GamerM
    May 5, 2020 at 15:05
  • do i have to download java 8 and also how because when i put in the java 8 thing it says it cant open java runtime Nov 3, 2020 at 13:45
  • Yes, you need to install Java 8.
    – MrParrot
    Nov 9, 2020 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .