I just started playing Skyrim yesterday.

I was annoyed enough by the opening cut scene that I didn't rush off to Riverwood as the game wanted me to, but instead ran around doing a little murdering and questing first.

I'm up to a level 6 wood elf who has a cool sword I found in a dungeon. I have murdered many bandits and others along the way.

But the time came to continue the story, so I went to Riverwood (or whatever it's called) to find Alvor. However, every time I approach the idiot, he and two others attack me! If I kill him, I'm allowed into his home with some Roman soldier looking dude. But the roman is boring, and I just end up killing him for being useless.

I have tried walking into the town without weapons drawn. And no matter how I run away and wait, etc, the jerk won't stop trying to kill me.

I want to get on with the story but don't know what to do after I am forced to kill the stupid hunk of meat. Nothing happens. I am able to get quests from other people in other towns, but I really want to play through the story.

I fear that I'm going to have to start a new character, and this frustrates me because I don't want to lose all my skills, my cool sword, etc.

Is there an evilness gauge or something that I need to bend the other way?

  • Have you tried yielding to him? (Draw then sheath your weapons in front of him) Commented Dec 2, 2011 at 21:06
  • @RavenDreamer no I have not, sounds like a good idea. It will be tricky because 2 others are also attacking me. I walk up sheathed, pull it out, then put it back? Will try. Commented Dec 2, 2011 at 21:08
  • exactly. You should yield to all 3, with any luck. Commented Dec 2, 2011 at 21:09
  • Well, there may be no gauge for evilness(attempt at realism), but you have murdered quite a few people. Perhaps some time in a jail will help...
    – Domocus
    Commented Dec 21, 2011 at 20:57
  • The Roman is an Imperial.
    – Jim Jones
    Commented Nov 20, 2015 at 4:31

9 Answers 9


If this is still happening to anyone, just run to Whiterun and pay the fine. Then fast-travel back to Riverwood and the problem will be fixed. Happened to my brother just there.


Usually, if friendly people are attacking you, it's because you've done something. you might want to check if you have a really high bounty or something.

You can yield to a (group of) person(s) by sheathing your weapon in front of them, and if your yield is accepted, they will stop attacking you.

  • 1
    This game has such complicated mechanics, why isn't any of this explained in-game? :\ Commented Jan 2, 2012 at 23:40
  • There's a great help section available in the menu. Commented Jan 3, 2012 at 2:34

I had something similar happen on the PS3. I accidentally stole a mug in Dragon's Reach and everyone started attacking me. I sheathed and unsheathed my sword but it didn't help. I fast-traveled to Whiterun and Alvor (along with the rest of the city) attacked me there as well. It seems like a bug.

My only recourse was to load from a prior saved game. I now tend to manually save regularly.


If you are on the PC, you can try this command in the console to bypass Alvor:

setstage MQ102 30

Other than that, you can try finding a calm scroll (or spell) and see if you can get them to stop attacking you long enough to talk to him.

  • Great ideas, thanks. Unfortunately I'm on the 360 (can I open a console?) so won't be able to take your first suggestion. Commented Dec 2, 2011 at 21:19
  • @Frank nope, I'm afraid you can't do the console method on the xbox
    – l I
    Commented Dec 2, 2011 at 21:19

I killed him. My story seems to be going along fine now. I just got past the Grey Beards and I'm currently on another quest. Seems to be alright. His family didn't seem to mind, either.


tl;dr: Open console, then click on npc, and finally enter:


A small amount of time after my character went back to Riverwood with Esbern, he reached the final stage of vampirism. As he was inside the village, people started attacking Esbern and him, and the almighty Esbern fought back. Now, the only option left was to quickly flee, remove the vampirism state:

setstage 000eafd5 10

And finally, travel to any other city, and travel back to Riverwood, click on the guard and enter:


This worked for me. What I did was I just did a bunch of side quests and stuff like that and after a while they just seemed to forget about it and stopped trying to kill me.


Go to Whiterun and talk to Jarl Balgruf the Greater. The story will continue as it should, you just skip the talking part with Alvor.


Apparently, this is a glitch, try to yield him, or you can go straight to Whiterun and talk to the Jarl for the next quest. [So you don't really need to talk to Alvor or Gerdur and then talk to the Jarl, skip]. Worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .