I was given the Shill job quest to place a gem in Heimskr's house in Whiterun. The problem is that if you have already completed the Stormcloak Rebellion questline, Heimskr's house is gone - it is covered by rubble and does not appear on the map. The Wiki makes note of this and suggests using the console to advance through the quest, IF you are playing on a PC. I am, but while this can "finish" the quest, Vex will not offer you any more jobs when you return to her - the option simply isn't in her dialog. Any suggestions?

  • possible duplicate of Where is Heimskr's House?
    – Rory
    Aug 12, 2013 at 15:10
  • @Rory: Well, kind of, but this builds off of this, talking about a problem that arises after listening to the answer in the other question. Aug 12, 2013 at 16:39

3 Answers 3


I've had the same problem before.

Where is Heimskr's House?

I believe the only solution is to go back to Vex and decline the quest. Then she'll give you something else. Either that, or re-load to a point before you got the quest and hope that she doesn't give it to you again. As far as I'm aware, you can freely reject these quests and ask for a new one until you get one that suits your needs.

See also:

UESP - Skyrim: Thieves Guild (Faction) - Improving the Thieves Guild
UESP - Skyrim: Heimskr
UESP - Skyrim: The Burglary Job - Bugs


I had a similar issue and used it as an excuse to learn more about how Skyrim is put together.

The issue has to do with the fact that the Thieves guild radiant questline is a complicated mixture of quests (eg: TGRSL) depending on other quests (eg: TGRShell) and all kinds of inconsistent weirdness between them such that, if you use console commands, you can cause the whole thing to be in an invalid state. It does seem like it would be possible to fix this problem, but I doubt Bethesda's priority is to make console commands safer. Fortunately, you can correct the invalid state in TGRShell.

Long story short, these are the console commands (~) you can use to fix it (fixed it for me at least). TGRSL is the quest ID for Vex's heist job. This is what I advanced. If this isn't what you advanced, replace the "TGRSL" in the first command with the quest ID you advanced:

SetPapyrusQuestVar TGRShell pTGRSLRun 0 
SetPapyrusQuestVar TGRShell pTGRVexRunning 0

You can verify that these variables were changed with this command

ShowQuestVars TGRShell

(Use PGUP/PGDOWN to scroll).

Now Vex should offer quests again. I hope this helps someone.

  • This should be marked as the correct answer -- I found this question when searching for a solution to this exact problem and those commands fixed it. Thanks!
    – Herohtar
    Sep 8, 2014 at 6:30

Install the Unofficial Skyrim Patch (original / Legendary Edition - PC) / (Special Edition - PC) / (PS4) / (Xbox One). Its related fix (v1.1 - 2012-08-03):

Thieves Guild radiant jobs will no longer select Heimskr's house as a target due to it being destroyed during the Battle of Whiterun.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .