I have just initiated three members into the blades and Esbern gave me my first quest with them to go and 'Kill the Dragon in Skyborn Altar' but I have already killed that dragon and so when we show up there is no dragon to kill.

I have tried using resetquest BQ04 in the console (BQ04 is the quest ID for the Jarls bounty to kill the Dragon at Skyborn Altar) however this does not work and there is still no dragon there. I do not know the quest ID for this specific quest and haven't seen it online but if I had it I could probably just use the setstage command to get past this bug.

Does anyone know what it is or know how I can find out?

  • That kind of stupid and obvious bug is exactly what made me quit Oblivion mid-game. Shame on devs. Commented Feb 15, 2012 at 15:50

2 Answers 2


The altar dragons actually respawn, it just takes some time. Perhaps do some fast traveling, or use Wait (but not at the altar). Many reports are that re-spawning takes 30 in-game days, but I've had locations take only 10.

I just tested Skyborn Altar. 10 days was sufficient for the dragon to respawn. I find it fastest to look at the date on the map screen at bottom right, add 10 for your target, and fast travel the longest distances to pass time. Markarth<->Riften is ~26 hours.

From my experience if you arrive too early you will have to wait all over again, better to load back before the arrival.

  • 3
    +1 for the early arrival as that will generally reset the counter until the area resets.
    – James
    Commented Jan 27, 2012 at 19:26
  • I'll add that respawned dragons will generally not give you dragon souls. I reloaded one save probably a dozen times, killing the same dragon over and over, because I was afraid I'd gotten bugged and was worried the lack of a dragon soul was going to cause problems later on. Turns out it was normal though.
    – Kromey
    Commented Jan 28, 2012 at 0:11
  • 1
    @Kromey Sounds like a bug to me. I kill a dragon, I get a dragon soul. I just tested a few more times at Skyborn Altar, soul each time. :-/ Commented Jan 28, 2012 at 0:46
  • @ChristopherGalpin I don't know the details but it is definitely normal not to receive multiple souls for static dragon respawns.
    – agf
    Commented Jan 28, 2012 at 12:32
  • @agf & Kromey, So I went on a dragon slaying tour to all the altars to figure this out. Each location long since cleared. Many an Ancient Dragon soul was found, until I found some plain Dragons (perhaps spawned much earlier in my game) which didn't decay, no soul. The subsequent respawns though were Ancient Dragons, for which I always received a soul. Somehow level/type based perhaps? Here's an oddity though, the Ancient Dragon at Ancient's Ascent (SW Helgen) never gives me a soul, period, on any respawns. Everywhere else does. Commented Jan 28, 2012 at 14:42

I know this is a late reply, but the questid is freeformskyhaventempleb, and typing

setstage freeformskyhaventempleb 20 

should solve your problem! :-)

  • 3
    Don't be worried about late replys. It doesn't matter if a question is 2 minutes old, or 2 years old, you should always feel free to answer it. Welcome to the site :)
    – Wipqozn
    Commented Feb 15, 2012 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .