A friend of mine just got borderlands GOTY, and its been crashing right from the start. Looked around and havnt found much, even in way of "things to try" so thus have asked here.

The game's splash screen comes up, and then it just crashs with the error "Failed to enter MenuMap: Failed to load package 'MenuMap' Please check log for errors" followed by a heck lot of normal error stuff (such as Address = 0x355ac850 (filename not found) GetOutermost() Address 0x75006e ect)

However the error code (after "load package 'MenuMap') seems to scream "I cant find borderlands.exe". (Has a lot of "Cant find file Borderlands.exe")

Does anyone have any useful info about this error, and ways to fix it?

The game works fine on my PC, but not for my friend, and I've even tried running his borderlands files on my pc, and it works fine, however my files will still give the error for him.

Thanks (I'll post screenshots later when I have the chance)

P.S The OS is Windows 7

P.S.S we have tried the following:

  • Checked game cache with Steam
  • Reinstalled DirectX
  • Tried running with files from two other computers (mine and a mates)
  • Reinstalled C++ 2008
  • Deleted "blob" file (might not be correct name) which let Steam reset its downloads



Error Screenshot

  • Out of curiosity, is this on Steam? Or a standalone copy of the game?
    – Niro
    Commented Jul 25, 2012 at 0:40
  • I dont think there is a standalone copy, you have to have steam for both retail and on steam store.... but yes on steam Commented Jul 25, 2012 at 0:42
  • Have you tried going into the properties and verifying the integrity of the cache?
    – Niro
    Commented Jul 25, 2012 at 0:43
  • yes, thats the first thing he did, he's also tried using the files of both mine and another mate's. Both have given the error. Also reinstalled Diret X, and ran with the compatiabily settings Commented Jul 25, 2012 at 0:44
  • Sadly, that is as far as my troubleshooting PC games goes. =( Just wanted to try and shed some more light on the situation.
    – Niro
    Commented Jul 25, 2012 at 0:45

3 Answers 3


You might try some of these (I would try Gvaz's fix before a full wipe), or this fix. Hopefully you get it fixed!

You could also try renaming nvcpl.dll in the Borderlands\binaries folder, think I saw that on Reddit a bit back.

Edit: In case threads go down, here are suggested fixes:

  1. close steam
  2. rename borderlands folder
  3. start steam and the download started by itself and finished
  4. shut down steam again, deleted the new folder after copying over to the old one, renamed old one
  5. started steam, and I could play the game.

Second fix:

  1. i deleted all my microsoft visuall version and installed the 4 that are mentioned in this thread: http://forums.gearboxsoftware.com/sh...d.php?t=114803
  2. i switched borderlands language to english
  3. i have to get rid of the "write-protection" of my steam order everytime before i want to start the game.

Try this last!

After trying everything i mentioned a few times and other semi-fix attempts i decided to nuke and pave. With a fresh install of windows and 1.40 borderlands works. It seems for one reason or another the patch and/or something working together on my previous install may have corrupted/screwed up one of the two dlls that borderlands error is complaining about (i replaced the first one, couldnt replace the second one as it was write protected).

  • Could you copy the potential fixes into your answer, in case those threads ever go down? Commented Jul 27, 2012 at 16:38
  • 1
    My mate got it working by "turning off his anti virus" or that's what he told me. When I find out more I'll put it here Commented Jul 28, 2012 at 4:57
  • 1
    @GarethJones well, at least he got it working. Do please follow up with the fix.
    – Phill.Zitt
    Commented Jul 28, 2012 at 8:04
  • Mate just says all he did was turn the Anti Virus off, and it worked. Also he pointed out that the fix about nuke and pave may be wrong, because the error only occurs on borderlands 1.41 and later Commented Jul 29, 2012 at 21:36

Going through your screenshot image shows two initial problems with Windows and then the rest (Boarderlands.exe) errors are probably an extension of the windows errors since the game can clearly launch before crashing.

The KERNELBASE.DLL is a system file. What you can do is try to make sure that the file is not corrupted. You can find instructions here off the Microsoft Website.

You can also make sure that your .NET frameworks are all up to date. If they are not, you can obtain the standalone installer for .NET 4 here and .NET 3.5 here.

The MSVCR90.DLL error is tied to a Visual C++ Library (which you have identified), but just to be sure, you can get the official download here.

If those are up to date and your graphic drivers are all up to date as well what you can try doing is creating a shortcut for the game on your desktop and running it in compatibility mode on Windows XP SP3.

  • -1 Kernelbase.dll has nothing to do with the .Net framework, and Borderlands doesn't require .Net to run. Also, he already mentioned that he reinstalled the Visual C++ framework. Commented Jul 27, 2012 at 16:34
  • I stand corrected, I've adjusted the answer. And I acknowledge that they have re installed the VC Library, but I just wanted to make sure all the bases were covered.
    – Sorean
    Commented Jul 27, 2012 at 16:55

Try deleting WillowGame\CookedPC\Maps\Menu_Map\menumap_LOC_INT.upk

  • 1
    Why? What does it do? Do you have a source for that? just randomly deleting files might not be smart.
    – Ids
    Commented Sep 30, 2012 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .