5

Just picked up this game today and I would much rather play it with my Xbox 360 controller. I'm having quite a bit of trouble however due to the fact that although I have my controller connected and working it does not seem to be usable in the game. Only the keyboard and mouse are recognized and I am unable to identify any options that may allow me to customize/enable a controller configuration. When I hit the home button I do get the GFWL overlay and the buttons/analog sticks are working fine in the overlay. I have also confirmed that I have the latest Microsoft Xbox 360 Accessories driver version 1.20.146.0 identifying the controller as player 1. What am I missing here?

I did also confirm that my controller was working in other games just as a sanity check.

1
  • I also just tried the game with my Logitech Gamepad F310 in X-Input mode. Not working :( Its about as basic as controllers get. Is anyone else having this sort of trouble?
    – NickSuperb
    Commented Sep 2, 2012 at 21:47

4 Answers 4

4

Found a solution on the Steam game hub..(scroll to bottom) http://steamcommunity.com/app/211420/discussions/0/882959061668056366?insideModal=1

Also, a more detailed source..(tip #5) http://segmentnext.com/2012/08/24/dark-souls-pc-crashes-low-fps-fix-controls-errors-freezes-and-gfwl-fixes/

The trick is to disable any of your devices listed as an "HID-compliant game controller". No need to uninstall. I created a system restore point JIC.

Control Panel > System > Device Manager > Human Interface Devices >> [Disable all of your devices listed as an "HID-compliant game controller"]

Remember to restore them when you're done. Quite a pain :| All things considered, its working now and that's fine with me until its patched.

5
  • 1
    I've had this problem with other 360 controller-enabled games - they seem to just take the controller that was connected first (or was installed first or something, I don't remember too clearly) and ignore the rest. You don't have to disable the devices, you can just unplug them.
    – Seyren
    Commented Sep 3, 2012 at 9:44
  • I tried unplugging all of my other devices including my keyboard and mouse. That didn't work.
    – NickSuperb
    Commented Sep 3, 2012 at 14:40
  • Weird. Maybe they changed the way it works. I've gotten rid of my old controller so I can't test it any more though.
    – Seyren
    Commented Sep 4, 2012 at 1:03
  • I think it may also have to do with the fact that i've also got a Logitech G13 and its plethora of associated device drivers.
    – NickSuperb
    Commented Sep 4, 2012 at 4:20
  • I tried the suggestions to just reinstall the drivers but it didn't make any difference, the HID-compliant game controller devices must be disabled in device manager- also I am using a G13 as well (although it seems to be functioning even with the devices disabled)
    – Jack
    Commented Nov 14, 2012 at 20:09
1

If all else fails just download xpadder.

1
  • 1
    Can you provide a bit more detail? What does xpadder do?
    – fredley
    Commented Nov 8, 2012 at 11:41
1

Xpadder is a great idea though. Tried to remap with this tool and it worked, but my configuration didn't save for some reason :\ I found this Xbox 360 Dark Souls preset instead, hope this will be helpful for someone!

enter image description here

0

I had drivers for my Razer Nostromo installed. I uninstalled them and I was able to use my gamepad perfectly with Dark Souls. So I guess the game has problems with certain drivers (other gamepad drivers or keypad drivers).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .