I have a scratched copy of Brigandine, an old game by Atlus on PSOne. I also have a PSOne. Now that we got that out of the way ...

I'm having trouble emulating this game from a ROM, and all of my google searches have lead to dead-ends. When I try with ePSXe v1.70, I can load it, start a new game, choose a faction, but that's it. It freezes at the loading screen afterwards.

When I tried with psxFin 1.13, it loads the game, however the main title screen 'flickers', and I can only get passed it by quickly hitting X button, but for some reason it auto-picks the "Iscalio" faction. (The one ruled by King Dryst).

Has anyone ever tried to emulate this game and done so successfully?

  • 1
    Hi, Marco. I've removed the bits about where to find a ROM or talk in chat; we don't condone piracy at all, for one, and any answers we get shouldn't be in chat, they should be an answer to this question. I hope you figure this out, though; ePSXe is my emulator of choice, and this game sounds interesting. You might want to check out Tactics Ogre, too.
    – Frank
    Commented Mar 26, 2013 at 16:52
  • 4
    This site's policy is that linking to ROMs is prohibited, discussing and troubleshooting emulation isn't. Until that policy changes, the question as it is now is fine. This site is not intended to discuss laws and jurisdictions, please keep those discussions out of the comments section.
    – Oak
    Commented Mar 26, 2013 at 18:50
  • So are you trying to emulate the scratched disc or a ROM you downloaded somewhere? In any case your first order of business it to get a (different) ROM and try that. Also, according to this topic, the game gets emulated perfectly by ePSXe.
    – kotekzot
    Commented Apr 5, 2013 at 18:33

2 Answers 2


As kotekzot stated, you might have a faulty ROM. If the games doesn't work for you on both these very fine emulators, and it does work for other people, my first guess is a bad ROM as well.

That said, here are some things to try out:

  1. Obviously, you can try downloading a new ROM from somewhere (sorry, I can't post any links)

  2. Try running the emulator as administrator, and possibly with compatibility settings set to windows XP SP2. You can do both these things by right clicking the emulator .exe (not the shortcut) and going to the compatibility tab. In this tab you can check a checkbox for run as admin, and choose XP SP2 in a dropdown menu.

  3. Change your emulator's settings. You can go in it's configuration and choose a different driver for cdrom and change some of the graphics settings. If that changes anything in the faulty behavior, chance are you might be able to fix it this way. Be careful not to mess it up for your other games, write down the old settings so you can always set it back the way it was

  4. Reinstall the emulator (kind of a last resort thing, try the rest first)


I may be wrong in assuming this, or your disc may be scratched to all holy hell, but...

Have you tried running this game from your disc? I could just be underthinking the problem but some emulators can do this, I was able to play my old scratched Tekken 3 from disc. I also cleaned mine and did the peanut butter trick to do so.

You must log in to answer this question.