2

My problem is that my PS3 controllers sync and start up the system properly. It maintains synced status, but the buttons don't work. The only button that works is the PS button. Also, when I am in the turn on-off menu, I can't get any of the buttons to work. If I press the PS button once, the battery appears to be fully charged. I've tried resetting the controller and plugging it several times. But, the problem is the same; it starts syncing, but the buttons are dead.

I have an Afterglow that's not wireless and works fine. What could the problem be?

  • 1
    Sounds like the controller's toast. – Frank Sep 24 '13 at 2:25
1

This isn't a problem that can be solved on this website. You're controller might be damaged on the inside. I suggest taking it to qualified Sony repair-shop and having it looked at.

  • Arqade is not a forum. – 5pike Sep 24 '13 at 10:17
  • fo·rum - fôrəm - A meeting or medium where ideas and views on a particular issue can be exchanged. – Vedant Chandra Sep 24 '13 at 10:24
  • Exactly - on Arquade, we don't discuss ideas and views on particular issues (except in the chat), because ideas and views tend to be opinion based. – 5pike Sep 24 '13 at 10:29
  • Okay I'm sorry, I've edited the answer. – Vedant Chandra Sep 24 '13 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.