4

Hardware/OS

  • CPU - Phenom II quad core
  • GPU - R7950 HD
  • RAM - 8GB
  • SSD - 2x120GB RAID 0
  • OS - Windows 7

Install Environment

  • Up-to-date windows
  • Latest beta catalyst drivers
  • Up-to-date game cache
  • No Mods
  • Other software runs fine (unlikely to be RAM)
  • Mouse trails disabled

Description
I have New Vegas (installed through steam), it's been running fine since its install half a year ago.

I was playing a save yesterday, and after a couple of hours I encountered something that seemed like a memory problem (glitchy, shaky movement, clipping issues), which led to a CTD after several minutes. I tried playing again today, and on passing the intro screens, I had no mouse cursor, and seemingly no keyboard input.

Edit: I was able to get into one of my saves using the arrow keys (should have thought of that). I have no mouse input in game period, or keyboard input (aside from dpad and return)

Edit 2 Going into the settings, there are no mouse or keyboard options period. Time for a complete reinstall of the game :( - the ESC key works for skipping the intro sequence, but no further.

Steps Taken

  • Restarted PC, jiggled the cable
  • I had an older catalyst driver, I updated to the latest beta (don't think this matters though)
  • Verified the integrity of the game cache
  • Deleted and allowed the game to re-create the .ini settings
  • Searched for 3 or 4 pages and found no similar issues
4
  • Try doing system restore or file restore to an earlier date that the mouse was there, back up your save file before you do this.
    – Charkz
    Commented Oct 24, 2013 at 11:06
  • @Wojtek'Charkz'Hordyniec I would NOT recommend this. He only has problems with his game, not the entire pc.
    – VascovdEng
    Commented Oct 24, 2013 at 11:08
  • I gave him two options, file restore or system restore. It could very be some mod, or something he installed that is causing the problem or a dodgy graphics card update but not in his case. It has fixed problems before for my friends when I done it. System restore is a save procedure if you know what your doing and back up anything important.
    – Charkz
    Commented Oct 24, 2013 at 11:10
  • 1
    After a certain amount of time, you will be able to accept your answer, which gives it a green checkmark and indicates that it resolves your question. There is no need to edit your question to indicate that information.
    – au revoir
    Commented Oct 24, 2013 at 12:15

4 Answers 4

2

Welp. My logitech controller driver changed in some way, or some kind of .ini thing happened, and new vegas decided to prefer it preferentially over everything. I saw controller mappings in the settings menu, unplugged it, and got mouse/keyboard input back. Plugging the controller in again cause the game to point out an option to disable 360 controllers, which I never paid attention to because I don't have a 360 controller (yeah yeah, 360 mode), and because this has never been an issue. I was about to reinstall when I noticed the button mappings in settings.

Thanks for your input VascovdEng and Wojtek. Sorry if I wasted anyone's time, hopefully anyone else with this issue will see this.

1
  • Solution: Unplug your gamepad.
    – Mazura
    Commented Feb 11, 2015 at 17:02
1

Hmm, upon googling your problem I came across this as the first link, this could be your answer, also go into your graphics options and disable 'Hardware Mouse Cursor" if the game has that option a lot of games do.

From Steam support

  • Please disable pointer trails for your mouse Start > Control Panel > Mouse > Pointer Options tab Uncheck the Display pointer trails box If you are using Windows 7, make sure the Magnifier is disabled: Start > All Programs > Accessories > Ease of Access > Ease of Access Center Click on Make the computer easier to see Uncheck the Turn on Magnifier box and click OK
6
  • I already have mouse trails off (in general, not as a step) - Nothing about my computer has changed other than the crash itself. Thanks though. Commented Oct 24, 2013 at 11:12
  • 1
    Right, I know my friend had a problem with another steam game, and weirdly it just came back after a day or two, could be a steam glitch, maybe your best bet would be to contact them. After googling it. It seems there isn't anything that is a straight fix just theories.
    – Charkz
    Commented Oct 24, 2013 at 11:14
  • Thanks for taking a look into it further, if this doesn't turn out to be a known issue I'll probably try a full re-install of the game(really not looking forward to that) Commented Oct 24, 2013 at 11:20
  • That could fix the problem, do you run any mods?
    – Charkz
    Commented Oct 24, 2013 at 11:25
  • As I said in my OP, no mods. I managed to get into a save, no keyboard or mouse input at all (details edited into OP) Commented Oct 24, 2013 at 11:30
1

I had the same problem, but in my case, it turned out that the xbox controller (or any another controller) plugged into my PC leads to this strange cursor/enter/backspace problem. So check that you don´t have any another control devices connected at the same time.

-1

Go into control settings and turn off 360 controller. Worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .