I made a bukkit server on my computer running OS X. No problems there. I opened up my client (on the same computer), open multiplayer, the direct connect and typed in "". It appeared to accept that. It showed "logging in" (I am using a premium account). Then it would fail and give me the error "End of Stream". The server console showed that my disconnect was a "genericDisconnect". Any idea why this isn't working?

Note: My internet is ridicoulsly slow. I don't live in the U.S. or an European country. Upgrading internet isn't an option. I however didn't think that the internet would matter if it was on the same computer as the client.

EDIT: I made a vanilla server, setting up server worked fine. When I tried to connect using I got this error:

2013-11-11 13:54:29 [CLIENT] [INFO] Connecting to, 25565 2013-11-11 13:54:33 [CLIENT] [INFO] [CHAT] DonyorM joined the game. 2013-11-11 13:54:33 [CLIENT] [SEVERE] Reached end of stream for /

The error shown on the client was Internal Exception: java.io.IOException Connection reset by peer I got the same error when connecting to a powerful public server in europe. I still get the end of stream error when using the bukkit server (which is 1.6.4, the vanilla server is 1.7.2).

When trying to connect using my external ip address and the port, I got a Connection Refused error. I think that's the wrong ip address.

  • Does the same thing happen if you try connecting through your actual IP address? Nov 11, 2013 at 16:20
  • Have you joined other multiplayer servers successfully? Have you tried hosting a regular MC server?
    – kotekzot
    Nov 11, 2013 at 20:08
  • First, run a vanilla server and see if you have the same problem. If you can connect to a vanilla server then it's a bukkit configuration problem; if you can't, then there is something external to the server wrong. Nov 11, 2013 at 20:42
  • @Studoku I think I tried that, and I couldn't connect at all. I should type in <myexternalipadress>:25565 right?
    – DonyorM
    Nov 12, 2013 at 1:50
  • @SevenSidedDie Did the vanilla server didn't work, see post above.
    – DonyorM
    Nov 12, 2013 at 2:58

5 Answers 5


Try manually specifying the client version in the launcher. Start the launcher, click Edit Profile, then under "Use version" specify the version compatible with your CraftBukkit server.

I received the same error connecting to both the stable (1.6.4) and beta (1.7.9) versions of CraftBukkit, but I could connect to a vanilla server (1.6.4) on the same remote machine without issue. The clue that tipped me off was connecting to the beta server returned an error that said "outdated server, I'm on 1.7.9!" My client is currently 1.8. I assumed the latest client was compatible with older servers, and for the vanilla server that seems to be the case, but for CraftBukkit you may need to manually specify the version.

  • I did this a while ago, but I made sure it was the right version. CraftBukkit was updated to the lastest version at the time. Right now, I've stopped bothering with a server and moved on to other things.
    – DonyorM
    Sep 3, 2014 at 8:06

If you have any firewalls, try disabling those. Also, in your server.properties, try changing online-mode to false. This will disable authentication of Minecraft accounts so cracked players will be able to get onto your server. If you are just hosting it at home for your own pleasure, you should be OK.

  • Tried all of those things. Doesn't work. I'm pretty sure it is the ping :(
    – DonyorM
    Dec 8, 2013 at 2:35
  • It shouldn't matter if you are hosting it on the same computer. You can disable your internet and still connect to a local server.
    – aman207
    Dec 8, 2013 at 3:25
  • What ip do I use? I used and it still gave me an end of stream error.
    – DonyorM
    Dec 8, 2013 at 4:57
  • Try simply using localhost.
    – aman207
    Dec 8, 2013 at 5:06
  • Having problems getting the jar file to work. Not server related. Have to wait for it to download the 1.6.4 jar. Can't try till it finishes.
    – DonyorM
    Dec 8, 2013 at 6:30

Since you can connect to neither local nor remote servers, this seems to be a client problem. "Connection reset by peer" basically mean that the server hung up and tossed you out (but that you managed to connect in the first place!).

This common practice if the client does not act as expected, either because of corruption or (more likely) an outdated/buggy client installation. I would suggest that you reinstall your Minecraft client and ensure that you test it against the vanilla servers before applying any kind of third party patches/mods (which is quite common in the world of Minecraft IIRC).

  • Thanks, I'm going to test it on another computer in this house, so I can really test it then.
    – DonyorM
    Jan 16, 2014 at 2:31

The problem is when connecting to a local server on the same machine you dont use the external ip. You use the internal one, this is the ip that the router gives you, usually 192.168.1.xxxx. To find this check the status of your internet connection. It should be listed there. If your still lost i will get on my mac and give you specific steps

  • I think you are missing at least a couple of points here: 1) He cannot connect to any server, not just his own. 2) He is already using LAN IPs when testing against his local servers.
    – Zero3
    Jan 15, 2014 at 19:31
  • Yeah, Zero3 pretty much said it. Also, consider adding punctuation and such to your posts. IT's a lot easier to read.
    – DonyorM
    Jan 16, 2014 at 3:11

Type in localhost:25565 when you want to play alone. Type localhost when you want friends to play with you.

  • 1
    Does it make a difference? I don't think it does.
    – DonyorM
    Jan 26, 2014 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .