3

So, for some reason my Minecraft keeps unresponding.

I've tried updating Java, completely deleting my .minecraft folder and re-installing Minecraft and everything but it never seems to fix my issue.

If I open Minecraft and don't leave the window, I can play it for as long as I'd like and it works fine.

If I ever switch to Chrome or something else from my Minecraft window and then go back to it, it'll show that it's unresponding and then if I click anywhere it goes fully grey and says loading.

I've let it load for up to an hour and it never actually works.

If I close my Minecraft and run it again, it will work fine until I leave it.

This issue has been going on for a week or so.

enter image description here

  • What do you mean by "If I open Minecraft and don't leave the window, I can play it for as long as I'd like and it works fine.?" – DatEpicCoderGuyWhoPrograms May 22 '14 at 22:44
  • I mean, aslong as I don't leave the Minecraft window to go into Chrome or something else for even a second, then it'll work fine. And won't show the not responding error at all. – user3646954 May 22 '14 at 22:46
  • Not impressed right now @DatEpicCoderGuyWhoPrograms. If you're not here to help then leave :/ – user3646954 May 22 '14 at 22:56
  • Nothing specifically. – user3646954 May 22 '14 at 22:59
  • Actually, when you go to open up something else, do you minimize minecraft or manually change the window size? – DatEpicCoderGuyWhoPrograms May 22 '14 at 23:00
1

Pretty strange problem, I've never seen it before. If I were you I would go over to your startup page (launcher) and click "Edit Profile" on your main profile and follow these steps:

  1. Find the button that says "Launcher Visibility" and check the checkbox.

  2. Select the dropdown menu to the right of the checkbox, once open select "Keep the launcher open".

  3. Save profile.

  4. Once saved you should return to the home screen, from there you should see a top menu with 3 tabs: Update Notes, Development Console and Profile Editor. Click Development Console.

  5. Press play and do what you need to do to get it to not respond.

After you have completed all of those copy and paste the text in the development console and send it over to Minecraft Support (https://help.mojang.com/) and post a thread with the text from the development console. They should be able to get into depth on how to fix it! Good luck!

0

My Experience:

From what I can understand, this issue has nothing to do with Minecraft but with Java itself and its interaction with operating system libraries.

I recently got a new hard drive and installed the latest version of Java and the Java Development Kit (1.8.0_05) (I am a programmer so I have use for it). Since then I have been having this problem. Before I got my new hard drive, I had updated to Java 1.8.0 and copied it to a flash drive so I could play Minecraft on a computer without Java installed. The previous version of Java I had been using (JDK 1.7.0_40) was working flawlessly and I was able to interact with it very flexibly. The problem arose when I updated to Java 1.8, I was using a program called Transparent Windows which is supposed to make a window semi-transparent to be able to view 2 windows stacked on top of each other (ex. Minecraft and a web browser). When I was using JDK 1.7 Transparent Windows worked as it should and allowed you to right click on the title bar and select a "Transparency" option.

This indicates to me that starting in Java/JDK version 1.7.0_60 (that is the closest I can find to 1.7.0_40 on oracle's website) Java has not been able to access or find Windows' native libraries, and as such becomes unresponsive in such a bizarre manner.

My solution:

Track down a copy of the JDK 1.7.0_40 or earlier and launch the game using it, or try downloading the 32 bit (x86) copy of the latest Java. I have not extensively tested the 32 bit version but after a few hours of continuous play I have not had this "Not Responding" issue.

Note: Do NOT change the javaw.exe compatibility. I have tried this for multiple versions of java, and attempted changing compatibility for both Minecraft.exe (the launcher) and javaw.exe (Java). This appeared to work at first but after a few hours the problem came up again only in a different form. Instead of getting the "Not Responding" problem the game will instantly crash, giving you NO possibility of saving your game or disconnecting from a server safely. There is no warning when this happens, it will stop responding and instantly say that java has stopped working. At this point the only option is to "Close the Program".

Edit: I have now tested the 32 bit versions and have the same problem. Just find an old version of the java dev kit or JDK (between 1.7.0 and 1.7.0_40)

-1

Changing the javaw compatibility mode to windows 7 fixed it for me.

protected by Community Jun 7 '14 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.