I'm trying to play Splinter Cell: Conviction on a Mac and it crashes on first load.

Remedies tried:

  • Reinstall Steam
  • Reinstall game (delete local content then redownloaded)

The last Console message is

Game removed: AppID 33220 "Tom Clancy's Splinter Cell Conviction", ProcID 2029.

Before that, there are a series of Assertion Failed errors on installscript_posix.cpp, including Failed on chmod action and Failed on defaults action.

Any ideas how to fix this?

  • Failed chmod action would seem to indicate that it's a permissions issue. Have you modified the permissions of Steam's location or the game data location? May 30, 2011 at 18:13
  • After seeing this issue, I chmod'ed the game's directory in steamapps to 777; the issue still occurs. Also: the errno claims no such file, but I've checked that the files do indeed exist. May 30, 2011 at 18:28

3 Answers 3


Turns out the computer had two profile folders; one had hung around from a previous install. Despite the errors about Failed on chmod action listing the new profile folder, it seems Steam was looking in the Library of the old profile folder for the appropriate data. Deleting that user, then deleting local content and reinstalling from Steam cloud fixed the problem.


I had the same problem, and I realize it was because I had the xbox controller connected. When I disconnected it, it worked! Try that.


I had the same thing. Finally I went in and looked in the package and ran it from the link in there instead of from Steam. It worked.

I went back to Steam load and it crashed. ODD - the only difference was the steam info overlays where in the lower right corner. so I tried to load it again but this time I hit shift tab a couple times to eliminate the steam overlays in the lower right.

It loaded fine. I tested it a few times with same result. Seems really odd to me, but so far my tests have all been the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .