5

I have Sim city 4 Deluxe (for some reason it is the UK edition even though I live and bought it in North America) and it was working fine for a few months, but recently after updating Windows, it stopped working. I have been reading online and tried a few different things, I know someone else here had the same issue, as shown in this post...

SimCity 4 Deluxe stopped working in Windows 7

But I don't have Kaspersky, and I tried disabling all my anti-virus and anti-malware software (I just have Microsoft Security Essentials and SpyBot Search and Destroy)

Anyone have an idea of how to proceed to troubleshoot it?

It was working perfectly, more or less on my machine (Win 7 64 bit, Intel Core 2 Duo E8400, AMD Radeon 6800 HD, 4GB RAM) a few weeks ago but then after updating it won't launch. Heres what I've tried so far:

  • Tried all compatibility modes, before I needed to put it into XP service pack 2, now nothing works.
  • Updating game.
  • Getting latest graphics card drivers
  • Turning off anti virus.
  • Reinstalling
  • Installing on another machine, I tried it on a windows 8 machine still nothing.

Any other suggestions? I've tried to see the process in the process list to see if it launches at least but nothing appears. So the game just dies on me as soon as I click the run button.

2

So I found out the reason why the game was not running, it was due to a recent Windows Security update, specifically KB3086255

The answer I was looking for actually came from someone having trouble playing Civ 4

http://forums.civfanatics.com/showthread.php?t=552140

They suggested you could either uninstall the update or run the following script to re-enable SecDrv, the anti-piracy software that was disabled by the update.

  • Open a command shell by pressing Win+R then type cmd and press enter
  • type sc config secdrv start=demand and press enter
  • type sc start secdrv and press enter
  • When you are done playing, type sc stop secdrv and sc config secdrv start=disabled to prevent a security issue

For me re-enabling SecDrv didn't work, but other people seemed to have more luck.

I uninstalled the windows update and that fixed the issue for me, so now the game works.

-2

Uninstall - Then - Reinstall - In the Folder Without the x86 for Windows 7 - Any!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.