2

My friend has a laptop that he runs a server on for just me and him to play on. This server always worked, whether it be modded or vanilla, there were no problems at all. One day it just stopped working, we changed absolutely nothing between the two days but it just stopped working. We've checked the internet for hours but no one else seems to have the problem we have to this extent. When he hosts it I can ping it, see the motd, the amount of players, but when I try to join I get an "IOException: connection forcibly closed my remote host.". I tried to run the server myself and I can join it fine but he gets the exact same error. I decided to try to connect to his server from a different connection with the same computer and it worked perfectly fine, but this connection won't work. We've tried:

A VPN and that worked fine, but was unplayably laggy.

Checking absolutely everything we can, all firewalls are off.

It's port-forwarded correctly (because I could join on another network).

There're no banned IPs (Because when I hosted it was a fresh new server).

There're no plugins that are harmful to the server, no plug-ins at all for that matter.

We've factory reset our routers.

We've tried everything and nothing will work at all. Please help

2
  • By chance, don't post the IP that was being used but where you two using the public IP address to connect, or an internal (192 or 10) address?
    – NBN-Alex
    Commented Feb 2, 2017 at 20:19
  • @NBN-Alex | We used the public IP addresses, I say it plural because we both tried hosting. Commented Feb 21, 2017 at 7:29

1 Answer 1

-1

He should contact his ISP and ask them to enable port forwarding. Generally only business level internet accounts have that option standard.

2
  • Port forwarding is usually a home router issue. ISPs won't deal with that. - What you're thinking of is a Static IP (which business class internet tends to get/purchase). Residential Internet usually gets a pool of IPs that are shared and changed out.
    – NBN-Alex
    Commented Feb 2, 2017 at 20:21
  • Also, it worked before, and port forwarding is working. Commented Jan 30, 2018 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .