I just finished the quest, "Blood's Honor" for Kodlak Grey-Mane, but there is an attack on the Companions before I can hand in the quest. Now, all the Companions NPCs are sitting and mourning all the time ("Forever Mourning" bug) and I can't get any new quests or anything.

How do I fix this and move forward in the quest line?


Got the same problem and i found this, http://www.uesp.net/wiki/Skyrim:Purity_of_Revenge#Bugs, a bug where the quest won't start beacause of the status of another quest.

Edit: I finally got this to work.

I'm not 100% sure what happend. But my initial problem was that I already had cleared the quest dungeon , Driftshade Refuge. So the quest did not start.

When I first didn't find any solution to this i just kept playing, and eventually i ended up in Winterhold and got the quest to fetch the helmet from the Jarl of Winterhold. Then i traveled to the dungeon again and all enemies had respawn (This is probably due to the fact that enemies respawn after 30 in-game days according to the wiki) and just rushed trough the dungeon and got the helmet, left the dungeon, handed in the helmet to the Jarl, then tried to start the Companion quest by console:

player.setstage c06 0  <-- Initiates Skyforge burial

And that worked =)

  • What if you have it on xbox.... and had the same problem. – user15543 Nov 29 '11 at 12:43
  • I don't know, does not have one myself. But I guess you're out of luck, using this method at least. I would guess you need to load a save before you finish the previous companion quest, wait 30 days (or to Driftshade has respawned), then turn in the quest. – Hmazter Nov 30 '11 at 16:05
  • i had this problem with my Xbox and read this post and just finished the game without it. Now, i went back to before i ever went to driftshade and it is doing the same damn thing! i checked, i dont have a bounty, and at this stage in the game i have not even located driftshade. i have at this point been given the quest to find the Helm of winterhold but havent done it yet. anyone got any hope here???? – user15801 Dec 3 '11 at 18:46
  • hmm i have the same problem except i CANNOT load a previous file since im lvl 53.. i just done the imperial storyline and thus retrieved the helmet for the jarl, all i can do now is wait 30 days? or am i screwed? – user16427 Dec 13 '11 at 23:44
  • @Tommystar yeah you should be fine with just waiting 30 in-game days, and then use the console. – Hmazter Dec 14 '11 at 20:28

Patch fixes

The "Forever Mourning" bug should now have been fixed as of the official patch v1.4 (2012-02-05) and v1.9 (2013-03-04). Related changelog:

[v1.4] Blood’s Honor will start properly if you visited and completed Driftshade and an extended period of time passes before starting the quest.

Before those patches, the Unofficial Skyrim Patch (USKP) had a fix for that issue. Related changelog from v1.3.0:

If Helm of Winterhold (Favor158) has started, Purity of Revenge (C05) could not start after Blood's Honor (C04) due to the location alias being reserved. The location alias for Driftshade Refuge has now been marked to "allow reserved" and "allow cleared" which enables Purity of Revenge to begin. (Bug #8200) [Official Patch 1.9]

The above USKP v1.3.0 fix has now been marked as fixed by the official patch v1.9. It has not been documented in the official patch changelog.

Manual fixes

If, despite having the latest Skyrim official patch installed, you still encounter the "Forever Mourning" bug, try one of the following fixes (from UESP wiki's "Purity of Revenge - Bugs" article):

  • If Driftshade Refuge has already been cleared, this quest cannot be started normally without a workaround. Before you begin Blood's Honor, wait 30 in-game days after you have cleared Driftshade Refuge to allow that dungeon to reset (you will have to revert to a slightly earlier save to do this). This should allow Purity of Revenge to begin normally upon completion of Blood's Honor. An easy way to check if the dungeon has been reset is to check the doors--if they have all been shut, it is reset (e.g., if the formerly barred door is barred again).
    • (PC only) The console may aid in fixing this. Click on Vilkas and use the disable and then enable commands, then use setstage c05 0 and talk to him.
    • (PC only) Another method that has worked is to reset the interior of Driftshade Refuge by typing ResetInterior DriftshadeSanctuary01 into the console. Then go and visit Driftshade Refuge and confirm that it is reset. It should be populated with Silver Hand fighters. Do this before talking to Vilkas, and when you do speak to him the next quest may start.
  • If Blood's Honor has already been completed and this quest won't begin because the Helm of Winterhold miscellaneous quest is active, it is possible to proceed through Driftshade Refuge without killing anyone (use stealth, fear or invisibility as needed) and take the Helm of Winterhold from the chest at the end. Once the Helm is returned to the Jarl of Winterhold to complete that quest, return to Jorrvaskr and the Purity of Revenge quest will begin.
    • (PC only) Another possibility is to complete the Helm of Winterhold quest by typing setstage favor158 20 into the console before talking with Vilkas.
  • (PC only) Should the "Retrieve the Helm of Winterhold" quest pose a repetition problem. Simply go to the Jarl Korir, take the quest one more time and enter setstage favor158 20 on the console. This quest shouldn't be a problem anymore. On the console, proceed by tapping ResetInterior DriftshadeSanctuary01. Then return to Vilkas and on the console, enter setstage c05 0.

I had this problem occur today on my PS3. I couldn't find any solid answers anywhere but luckily I found a fix. I wasn't sure if the misc quest for the helm of winterhold was part of the problem or not but to be safe I reloaded an earlier save point and completed this before moving on to Blood Honor. Afterwords I had the same problem and saw that if driftshade was cleared then this will cause the error, and I had already done this. With little hope, I waited a month in the game and went back to the companions and it proceeded to the next quest without complication. Between the Helm of Winterhold being done first and Driftshade being cleared out seems to cause the problem for sure. But I have confirmed waiting for a month to pass in the game has fixed the problem for me. I hope it does the same for all of you. Good Luck.

Not the answer you're looking for? Browse other questions tagged or ask your own question.