I've battled at the fort, but when I attempt to speak to Galmar Stone-Fist (to whom the quest directs me), he has no conversation options whatsoever.

I also attempted to speak to Ulfric, but the same thing occurs.

I think this question is glitched, and that the only way I can continue would be to use the console to advance. However, I can't find the ID on UESP.net as the page for the Haafingar portion still hasn't been created. I have no idea how to find the ID, either.

What is the ID for this quest, or how can I find it out myself?

  • At the console: help "Liberation of Skyrim" 0
    – Arkive
    Commented Nov 17, 2011 at 15:49
  • CWObj. But this wont help you, because you'd have to know the "stage" of the quest. I have tried everything between 1-1000, nothing works.
    – user14668
    Commented Nov 17, 2011 at 22:11
  • I got the same problem, but i have allready taken Solitude but it remains under siege and i dont know how i can get the siege to stop because most of my other quest rely on the possibility to enter Solitude. please help me
    – user14821
    Commented Nov 19, 2011 at 20:27

5 Answers 5


You can use the showquesttargets command in the console. You might need to scroll up with page-up. This will tell you the quest Id's for all active quests. (see here: Skyrim Wiki)


This worked for me: when you get to Galmar in the Village before the attack and he tells you to meet up with Ulfric infront of Solitude for attack, use "setstage CWObj 255" and go there. Do the fighting and then go back to Windhelm, wait for Ulfric to return and talk to him. He will make you a THANE and tell you to buy a house.

I can go back to Solitude now without a problem, everything is working.


Okay, so I have the bug where when you go in, none of your fellow stormcloaks are with you in the invasion except Ulfric and Galmaar.

What I did was enter setstage CWSiegeObj 255 in the console, before going to listen to Ulfric's speech pre-battle. Going in, I still had the bug symptoms going on, but I just went ahead to the room General Tulius is in and went about the normal quest routine, harming only one imperial guard so the scripted events could take place.

After that quest completed (receiving the reward) and Ulfric wanted to give yet another speech, I followed him outside and, voila, Stormcloak soldiers fighting the imperials in the courtyard. No speech, but checking out the reactions from Jarl Whatsherface and Ulfric on the outcome of the civil war, the quest completed apparently.

This may or may not work for the OP but I figure I'd post my findings here since this is where I got the idea to fix my problem the way I did.


There is a console command GetQuestRunning (getqr). I have no idea how it works as I'm having a similar problem with the final thieves guild larceny target quest. It does not appear to iniate when I find/loot the 'Eye of the Falmer'.


You can type SQS [quest ID] to see all the stages for the quest, for this one it would be setstage CWObj 255. Sadly this is not the solution to this glitch either because upon attacking Solitude killing guards there counts towards your bounty in that area, and invulnerable citizens will also attack you as if you just entered the city regularly and started attacking guards

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .