5

The Minecraft launcher recently updated to add support for Microsoft accounts, it also changed the background and added a warning when I hover over modified profiles in the selection tab (This installation has been modified and might not support the latest player safety features.). I always use the Fabric modloader and I don't care about not having access to the "latest player safety features" and I've kinda had enough of Minecraft nagging me every time I switch versions when I want to play on different servers. I am not going to accept "Stop using mods" as an answer, as I do not intend to do so. I have searched across google for answers but haven't been able to find information regarding this anywhere.

1 Answer 1

2

Go to the .minecraft folder in %appdata% and open the launcher_profiles.json file.

Scroll to the desired profile name (e.g. Optifine). Then change the "type" to "Void-Null". Then restart the Minecraft launcher with beta mode enabled in the settings.

Example of mine when done:

"OptiFine" : {
      "created" : "2020-08-27T07:48:53.976Z",
      "icon" : "Grass",
      "javaArgs" : "-Xmx10G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M",
      "lastUsed" : "2020-12-02T18:16:50.180Z",
      "lastVersionId" : "1.16.4",
      "name" : "OptiFine",
      "type" : "Void-Null"
}
2
  • It actually is better if it is formatted because it is much easier to read. Your answer can help many more people when it is formatted. I have suggested an edit to improve the formatting, but next time it is encouraged to edit it if you'd like.
    – Penguin
    Dec 2, 2020 at 19:01
  • 1
    Is this an official workaround? I can't find documentation of that exact profile type anywhere and it seems to have no effect for me. Dec 22, 2020 at 8:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .