9

After a long night of gaming with my boyfriend, finally making a nether portal and exploring for a bit, we logged off for the night. However, when I log on this morning to work on stuff, our whole house, along with the ground surrounding it, is just gone.

There are huge holes in the floor, along with small remains from our house and farm. I assumed it was a chunk error, so I tried resetting them, but it didn't work. I tried logging off and back on again, but it did nothing. I tried uninstalling and reinstalling my game, but it did nothing. I checked my other world, and it was completely fine, so I'm being led to the conclusion that the Nether may have destroyed the world; however, from the way the holes are formed it doesn't seem like damage from a mob.

enter image description here

enter image description here

Something else that I thought was weird is that some grass that we broke to make room for our farm and egg farm had regenerated. We had two rows of wheat, plus some space for fencing and lighting, and suddenly the grass is back. We also had a panda enclosure with some bamboo, and as you can see in one of the images, the ground under it is gone; but it's still standing tall and proud.

There is also a huge hole behind this area, and I'm really stuck on what the cause could be, because if it was mob damage, I assume it would be a lot less severe and more prominent. If it was missing chunks, it would've been a lot simpler to fix.

enter image description here

enter image description here

We've spent so much time on this world, and it would suck so bad to find out there's nothing we can do. I am running Minecraft version 1.17 on Windows 10.

I went back to check on the world. The MB's keep going up, yet there's no change to the world. I found some corrupt files after looking into my world files on my drive. Any ideas on how to recover them?

10
  • 2
    I see. I will keep that solution in mind. I'm having a roam around on other forums as other people seem to have the same issue. Will keep you posted! :) Jun 23 at 12:13
  • 2
    Does this answer your question? How can I get rid of this black hole in my minecraft world?
    – Joachim
    Jun 23 at 12:56
  • 1
    Looks like a chunk loading error and unfortunately can like not be fixed :(
    – Nate W
    Jun 25 at 21:57
  • 1
    @Joachim that's for Java Edition, this can't be a duplicate because it's a different game
    – Penguin
    Jun 28 at 16:57
  • 1
    Is the bedrock layer still there? If the chunk was corrupted it would be newly regenerated, so the only thing I can think is that the blocks were somehow replaced with air blocks. But maybe I'm missing something, that's one of the reasons I started the bounty :)
    – c1uq92
    Sep 7 at 0:51
5
+100

I found this on Mojang bug tracker that's still unresolved, and reported also for versions 1.17.0, 1.17.2 Hotfix:

This report covers any of the following occuring without a game crash:

  • Chunks (portions of the world) being wholly or partially (i.e. below a certain Y-level) deleted and turned to void/air
  • Chunks being reset to a state of initial generation (This may result in the chunk not matching surrounding chunks that were generated in an earlier version.)
  • Chunks reverting to an earlier saved state (usually the state the chunk was in before the last time that area of the world was visited)

Which seems your same problem. If you need a fix, there's none at the moment...

From a mod's comment:

Unfortunately, there is no way to make the chunks that have been voided come back. The data for those chunks is simply gone. The only thing you can do for future protection is make manual backups of your worlds regularly and restore one if new chunks get voided.

And regarding the technical reason for this, another mod wrote:

It looks like the data loss doesn’t always affect the entire chunk. In some cases surface (topmost) chunk sections are spared. I think this suggests the issue is related to loading optimization.

It's not clear why it happened, but the bug is known and a lot of issues have been opened. I suggest you follow the thread to receive updates as soon as they occur.

1

This is most likely due to the 1.17 update for Minecraft. Because they increased the maximum depth, some things can glitch out a lot. I'm afraid you can't change this glitch.

8
  • 3
    Can you provide a source or further explanation for this? This seems to be a very strange bug due to maximum depth changes.
    – user228576
    Jun 23 at 11:10
  • +1. I knew about the maximum depth changes but this seems a bit drastic. I appreciate I can't fix the glitch but surely, because it's a glitch, it'll sort itself out? Unless I'm wrong. Jun 23 at 11:17
  • @JessicaWinter unfortunately glitches like this (if, this is a glitch) won't be resolved as the data is lost. There's really no way (to my knowledge, unless it's a Realms server) to recover world data lost on a scale such as this. Sorry it happened to you. Best of luck! Jun 23 at 11:59
  • @Gnemlock When minecraft comes across something it doesn't like (unknown items, malformed chunk, etc.) it just straight-up removes it to prevent a crash or other weird glitches so it would make sense that in the update some of the data got malformed when converting it. I think this is a probable explanation
    – Penguin
    Jun 28 at 16:59
  • 3
    The max depth changes won't be released until the second part of the 1.17 update, much later this year. I'm shocked nobody else said anything... how could some unreleased feature cause that bug?
    – AJPerez
    Sep 7 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.