20

My primary monitor is a standard computer monitor, while my TV is connected via HDMI as a secondary monitor. I just installed the Steam beta and wanted to try out the new Big Picture mode, but to my dissapointment it opened on my primary display not on my TV.

Is there any way to make Steam open the Big Picture mode on the secondary monitor?

6
  • Other than setting your TV as primary?
    – MBraedley
    Sep 12, 2012 at 16:05
  • @MBraedley Yes, I don't want to do that as it causes other problems. And always switching the primary display when I want to use my TV for such stuff is also annoying. Sep 12, 2012 at 16:09
  • I had this sort of setup a while ago, and basically what I did was just have my two displays show the same thing (duplicate displays). That way I could just turn on the bigger one when I wanted to use it. But this means you can't really use both displays, since they both show the same thing.
    – GnomeSlice
    Sep 12, 2012 at 16:15
  • 2
    Isn't the answer "File a feature request, since it's still in beta"? Sep 12, 2012 at 17:34
  • @GnomeSlice: There's also a good chance that the two aren't the same resolution.
    – MBraedley
    Sep 12, 2012 at 20:50

5 Answers 5

8

Go to Settings/Display/Resolution then select Target Monitor you can change your target monitor on a drop down list.

enter image description here enter image description here

4
  • This works, but unfortunately it does so by making the target monitor your Primary Display, and it does not set it back when you exit. Dec 14, 2012 at 6:45
  • 2
    This has been fixed. It now makes the original display the primary one again.
    – DanMan
    May 1, 2013 at 17:12
  • The downside is that it keeps putting my desktop icons on the wrong screen...
    – DanMan
    Sep 15, 2014 at 8:35
  • 1
    This doesn't work with Linux.. they might have removed this setting from other platforms as well with the latest release of Steam & BPM
    – phil
    Oct 25, 2015 at 15:03
4

You can switch Steam Big Picture to your secondary display and back using:

Windows+Shift+ /

But this will only work if the primary and secondary display have the same resolution.

2
  • 2
    Doesn't seem to work in Windows 10
    – Eckstein
    Nov 24, 2015 at 4:38
  • 1
    Does not work on Ubuntu 14.04 either Jun 25, 2016 at 20:40
1

In settings of Windows 10 set need display as main. That’s all. Big picture will run on a new main display.

1

On MacOS, the cheaty solution I have found is just to go to your MacOS display setting and set you external display as the main display. Then Steam works exactly as expected.

0

On Linux, Steam Big Picture always goes to the primary monitor. You can select which monitor is the primary one using xrandr or arandr or Display Settings.

Source: https://bbs.archlinux.org/viewtopic.php?id=207721

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .