0

I'm trying to play "Batman: Arkham Asylum". I bought it on Steam and haven't played it yet. I downloaded it and, apparently, it was successfully installed.

However, every time I try to start the game I get a message box stating D3DERR_NOTAVAILABLE.

I'm running Windows 8.1 (when I installed the game, I had Win8, but I never started the game. Last night I updated to Win8.1 and then tried to run the game). I have all Windows Updates installed. I have Direct X 11 installed.

  • 1
    Many people in this thread found that uninstalling then reinstalling DirectX solved the problem. Have you tried that? – pushasha May 23 '16 at 18:51
  • @pushasha I really want to, but there's no standalone DX download for Win8 and up. How do I remvoe and then reinstall it? – That Brazilian Guy May 23 '16 at 19:30
  • Oy, sorry -- didn't notice there was no standalone installer. Sorry about that... now I'm out of ideas :( – pushasha May 23 '16 at 21:55
  • Steam games ship with the required files: check the game folder in C:\Program Files (x86)\Steam\steamapps\common\Batman Arkham Asylum GOTY and look for a folder called "_commonRedist" or similar. You should find (probably) the required VC and d3d redistributables there – Yorik May 24 '16 at 17:08
  • 1
    D3DERR_NOTAVAILABLE indicates either that your video card driver doesn't support 3D acceleration or doesn't support some frame buffer format or something else that the game is trying to use. Try updating your video card drivers. – user86571 May 24 '16 at 17:39
-2

It may be a steam failure, try to verify the cache. If it didn't help you probaly need to contact steam. I also had the failure on some off my own game's but that was a cache issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.