1

I was doing the Thieves Guild questline until I got to the quest Trinity Restored. I get out of the Cistern and go outside to the city of Riften. I try to leave Riften through the main doors and it loads forever. I relaunch the game and the issue persists. So this time I fast travel to the Windhelm Stables and pay to go to Riften, where the issue still persists. Does anyone know any fix for this?

I'm playing on Xbox One: Special Edition with the Unofficial Patch.

  • I don't know... have you tried entering by the other gate, or swimming to the docks and entering from there? – Lord Harkon Dec 31 '16 at 5:32
  • I've tried all doors, and how to i swim to the docks? – Tom Ribbertry Dec 31 '16 at 5:45
  • There are some docks on the west side of town. You can swim over and find a latter to let you onto the dock. Then you can find a door that leads into town. I doubt that it will help, if you've already tried both gates, but I don't know. – Lord Harkon Dec 31 '16 at 6:01
  • 1
    How long have you played that character? Do you have any other mods installed? There is a know issue with infinite loading screen caused by how the game engine allocate memory. There are fixes attempt by modders on PC, but those cannot be ported to console due to the usage of SKSE. Increasing the number of mods will increase the likelihood of this issue occurring depending on what they adds. Your best shot would be to go on the official bethesda forums and post a request for support with as much information possible. – xrogaan Dec 31 '16 at 12:14
  • 1
    You probably want to go on their forums. When I asked "how long", it's more about "how much did you do in the world" and less about the amount of time you've allocated. Also please specify what "loads forever" means, some times it may take a while to load a level. If you've been waiting for more than 2 minutes (to be safe), then there is an issue. – xrogaan Jan 2 '17 at 14:34
3

How to fix it?

Based on the information below, the question is less a matter of "how to fix it" and more a matter of "if it can be fixed (right now)."

You currently have a few of options, and a couple aren't ideal but may be the only recourse:

  • Disable the mod until your console receives the 1.3 update to the game and then enable the unofficial patch again.
  • Some issues like this may ruin a save file, and you'll have to start over or at least rollback to an earlier save.
  • Check your mod load order and ensure that the Unoffical Patch is loaded first before mods but after any official DLC (official patch addresses some of the DLC loading).
  • If you have other mods loaded, read the mod requirements and make sure they're loaded in order as instructed or not paired with a conflicting mod.

While a few users have fixed some of their issues by ensuring load order has placed the Unofficial Patch first (top), many others report CDT (crash to desktop) when getting near a populated area (Riften is one of the common cities CDT is reported to happen while using the Unofficial Patch).

Why this is happening

On January 9, 2017, Bethesda released an official patch for Skyrim SE and the game version is now 1.3 (1.05 on PS4, and I believe same versioning structure for XBox One). However, PC and PS4 were the only systems to get this update.

From the Bethesda site, the latest devnotes state:

The 1.3 Update for Skyrim Special Edition is available on PC and PS4. Xbox One update coming later.

UESSP shows the latest version of the patch is 1.3 to match what's available on PC and because the mods available to consoles are PC ports. UESSP states two clauses regarding the Unofficial Patch:

Note that this patch is unofficial. The official (Bethesda-released) patches are documented at Patch and Special Edition Patch; the official patches include some fixes that for technical reasons (e.g., altering the game's executable) cannot be incorporated into the unofficial patches. Therefore, installing the official patches is still recommended. Also, the unofficial patch is only available to PC players and Xbox One players on the Special Edition of Skyrim; - Unofficial Skyrim Patch

Please note that having a designated patch installed will not guarantee that the issue it was supposed to fix will be fixed upon entering game. In some cases after a patch has been installed players have noted that their previous save files have become unplayable, glitchy and other issues. As such it may be necessary to start a new game file to have all issues resolved. Skyrim: Unofficial Patch

From this, it seems part of why you're having this issue is because the Unofficial Patch addresses lingering issues of the official patch you do not have access to - meaning the unofficial patch has altered code that could cause bugs with official version 1.2 on your X BOX but not cause a problem with official 1.3 on PC.

Of note, many forums have flooded with XBox One mod and patch problems over both PC and PS4 in the past month (around the time the Unofficial Patch 1.3 was released). I can only speculate correlation, however.

This makes me angry.

A post on GameFAQs pointed out the Unofficial Patch has seen a growing number of problems, but that it isn't really a single party fault as much as it is a circumstantial one:

Right now there are issues with any mod that accesses the dlc.

Once bethesda has finished borking things up with patches and actually fixes the dlc file order issue then the patch will be fantastic. Even required by many mods.

That's an "if" though.

Right now it has its issues that Arthmoor can't really do anything about since they are on bethesda to fix.

Great...what else can go wrong?

A comprehensive list of bugs is under constant review.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.