1

I have a 70000 series slim PS2 in which the laser seems to have died, so I picked up a memory card with Free MCBoot v1.952 installed. I got the system to boot into Free MCBoot and everything looks great and OPL starts up fine.

I've had a very hard time finding any information with regards to how to get my games into the system, but here's what I've tried. Most of my work is done in Fedora 25, so I'm operating most of this from Linux. I set up a USB stick (yes, I know the caveats, but it's a slim system) as FAT32, and created the following directories:

  • CD
  • CFG
  • CHT
  • DVD

After accessing the stick through the PS2 and Free MCBoot, I also see these directories:

  • ART
  • THM
  • VMC

Using a very simple PS2 game I have, Namco Museum, I ripped an .iso file using K9Copy. Everything seems fine - I can mount the .iso, it looks like the original, etc. I copied this .iso to the DVD folder and named it slus_202.73.NamcoMuseum.iso. I also checked the config file inside the .iso and I see this same slus_202.73 identifier listed.

When I take this back to Free MCBoot, OPL sees the game and I am able to go to game settings (but didn't change anything) and select the game to run. The screen then turns white and nothing else happens. I don't get any colors flashing, etc. - just white.

From what I've found, this should just start up, but I can't seem to find any additional troubleshooting tips anywhere. Any help/suggestions are greatly appreciated.

  • I found an ISO online to test whether my ISO generation was faulty. When I tested it, I had the same problem - USB drive flashes, screen turns white, and then nothing further. Any ideas how to test or troubleshoot? – KirkD_CO Jan 16 '17 at 4:14
  • Just a bump in hopes that someone out there has an idea. – KirkD_CO Jan 20 '17 at 16:51
2

A very important point, make sure you are using OPL version 0.9+.

That said, your main problem is that you cannot simply install the game for use with OPL by extracting it and naming the folder accordingly. In fact it shouldn't even be in a folder, but the root of your USB device. In order to load games off of a USB device with OPL you have to use a particular Windows program (linked below) to automatically split the ISO into sectors to make it appear to the PS2 as though it is reading the data from a DVD or the loading will fail, OPL is only there to provide a way to read what is on the USB device, and to recognize when a game is there, the game is still processed as it would be when read from a DVD.

Which brings me to my second point, once you have properly installed the ISO using a given program (linked below) you have to use a defragmentation programme (namely PowerDefragment (linked below)) to make sure the game is completely contiguous, because if there is any fragmentation inside of the game on the USB device the game will freeze up and possibly cut out the same way it would with a scratched DVD.

As a side note I know you can also load games from a network using OPL, but I haven't the slightest clue how to do that, as I've never done it myself.

A second note: when installing games make sure you do it one at a time (install a game to USB device, scan device for fragmentation, defragment game if needed, then install another game, because if more than one game is heavily fragmented there wont be a large enough amount contiguous free space to move parts of a game to when defragmenting it.).

Unfortunately no matter what you will likely have to use Windows, and at the very least you will have to use Wine, because as far as I know there are no programs for installing PS2 games to USB devices on Linux, or macOS for that matter.

USB Util v2 can be found here [link] (http://www5.zippyshare.com/v/Q3u0srrl/file.html) Use it to install your ISOs to your USB device (FAT32)

PowerDefragmenter_3.0 can be found here, use the command line version if possible, the GUI has some issues if I remember correctly http://www.softpedia.com/get/System/Hard-Disk-Utils/Power-Defragmenter.shtml

First format your USB disk as FAT32, then run USB Util v2, select your ISO, wait for it to install, and use PowerDefragmenter_3.0 to scan your USB disk and repair any fragmentation. Make sure you have OPL 0.9.3 installed, and launch your game. It should run fine now, good luck!

BTW, this is what the game should look like once it has been installed, there are two in the picture, Metal Slug Anthology and Gran Turismo 4, the format for a game's name is ul.SERIALNUMBER.gameid.PARTand you should also have a file called ul.cfg
Picture of PS2 games installed on a USB device.

  • Thanks for the great info! Regarding the ripped/named files, that was exactly what another source said to do. Clearly not such good information. I downloaded both Windows EXE files and I'm running USBUtil through Wine now. I'll post back once I've had a chance to try it out. – KirkD_CO Feb 20 '17 at 22:28
  • @KirkDCO glad I could help, be aware that (at least on macOS) running USBUtil in Wine will cause it to think the amount of free space on your USB drive is the same as the amount of free space on your first HDD. Obviously not a huge problem unless you have paritcularly little free space, just something to keep in mind. Also have recently test the GUI for PowerDefragmenter_3.0 works fine after all, but make sure you choose to defrag files, not the whole disk. – Alison E.E. Feb 20 '17 at 22:55
  • Bummer. Same problem. I used USBUtil to copy the content to the USB stick and things look more or less like what you showed in the picture. I started up FreeMCBoot and went to OPL (which is version 0.9.3). I can see the game listed and when I select it the screen fades, the usb stick flashes, the screen turns white, and then....nothing. Same problem as before. – KirkD_CO Feb 21 '17 at 3:06
  • @KirkDCO did you make sure to defragment all the game's file using slots 1-4 in PowerDefragmenter? If so you might try using another flash drive if you have one to spare, some USB 2.0/3.0 disks don't work properly (for example both my USB 1.0 and one of my USB 2.0 disks work fine, but the other 2.0 disk and my USB 1.1 disk dont). Also make sure the partition table on the USB disk is MBR not GPT. – Alison E.E. Feb 23 '17 at 1:10
  • @Allison E.E yes, I did the defragment step, but I have not tried another flash drive. I'll give that a try and report back once I've had a chance to try it. – KirkD_CO Feb 23 '17 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.