I’ve been using a PS4 controller to play Fallen Order through origin by plugging it in with a micro USB. It accepts the DualShock 4 natively without any sort of aftermarket help. It even has the correct button graphics in game. (X instead of A, for example.)

However, when the controller is connected using Bluetooth (through windows, no aftermarket once again) the game doesn’t recognize it. Any idea why? I wouldn’t have guessed there would be any difference technically between plugging in and Bluetooth.

  • Are you sure the controller is connected to the PC through Bluetooth? And is this the case for all games, or just the one?
    – Ben
    Nov 28, 2019 at 2:04
  • Its connected, I know because its working on steam. Nov 28, 2019 at 2:22
  • Does it work with other games?
    – Ben
    Nov 28, 2019 at 3:00

1 Answer 1


The short answer is that DS4 behaves differently over Bluetooth than over USB. To get it working on Windows, use a third-party driver that makes DS4 inputs accessible through the XInput API. You can use Steam for this by enabling PlayStation Configuration Support and running the game with the Steam overlay. DS4Windows is another option.

The technical explanation is that DS4 can operate in two modes while connected over Bluetooth. DS4 defaults into a PC-friendly mode that provides button, thumbstick, and trigger inputs but excludes other features like the touchpad, gyroscope, and accelerometer. (Probably this is done to save battery.) The PC-friendly mode doesn't support vibration or changing the color of the light bar. To access the other features, a report must be sent to the controller to tell it to switch modes. Once it's in the full-feature mode, it stops sending the PC-friendly inputs. For more info, see DS4-BT on psdevwiki. Input report 0x01 is the PC-friendly report, input report 0x11 is the full-feature report.

My guess is Fallen Order either doesn't support DS4 over Bluetooth, or it only supports the PC-friendly mode. If you use your DS4 with Steam, it will already be initialized into the full-feature mode. Try closing Steam and turning the DS4 off and on again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .