2

I started a SkyFactory 4 modded world but now want to get rid of the bouncy creepers mod. However, simply going to the /mods folder and removing the BouncyCreepers-0.0.4.jar file will permanently break all natural hostile mob spawning when in-game afterwards. How do I safely remove this mod while still getting hostile mobs to spawn?

I've seen many encounter this issue, but haven't found an answer.

  1. https://www.reddit.com/r/SkyFactory/comments/ellofq/sf4_remove_bouncy_creepers/
  2. https://www.reddit.com/r/feedthebeast/comments/bfh5c9/skyfactory_4_hostile_mobs_not_spawning/
  3. https://www.reddit.com/r/SkyFactory/comments/cuhhm2/bouncy_creepers_sf4/
2

I did some digging around in the folder that contains my Twitch Launcher's SkyFactory 4 instance, using an IDE to find references to "bounc" (sic) or similar. In /logs/latest.log, I saw this:

[17:28:35] [Client thread/INFO]: Reading spawn rules from spawn.json
[17:28:35] [Client thread/ERROR]: Unknown mob 'bouncy_creepers:bouncy_creeper'!
[17:28:35] [Client thread/ERROR]: Unknown mob 'bouncy_creepers:bouncy_creeper'!

So, I removed the following lines from /config/incontrol/spawn.json (should be at the top of the file):

  {
    "mob": "bouncy_creepers:bouncy_creeper",
    "mincount": "18,bouncy_creepers:bouncy_creeper",
    "result": "deny"
  },

This was done with MC closed. I then saved the file, removed the mod's .jar, started up MC, and entered my existing world again. This time, hostile mobs now continued to spawn naturally despite the removal of the mod, and there were no such "unknown mob" errors relating to the spawn.json file in the game's latest log.

Note that you may get prompted about some missing EntityEntry/SoundEvent IDs in the registry while entering your world, which normally happens when removing a mod. Simply hit "yes" and proceed with the loading.

Also, I did get impatient while waiting as I didn't know if what I did worked at the time, so I did toggle vanilla mob spawning off and on again, after which I saw hostile mobs naturally spawn in a large dark room that I'd built (no, toggling mob spawning didn't work without the edits to the JSON file, and no, the issue isn't the fact that hostile mobs don't naturally spawn too close to or too far from the player). Therefore, if the steps above don't work for you, do this as well:

  1. Run /gamerule doMobSpawning false
  2. Wait a few seconds with the game not paused
  3. Run /gamerule doMobSpawning true

(I posted this QnA pair after finding the solution in hopes that it saves fellow players out there the annoyance of the bouncy creepers. The novelty sure does wear off fast.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.