1

I have a TF2 server which was working, up until recently.

When I try to connect, it always says this:

The server you are trying to connect to is running an older version of the game.

I have tried...

  • Turning on the -autoupdate flag: Did not work
  • Manually running the update via ./steam -command update -game tf -dir ./tf -verify_all -retry: Did not work
  • sudo'ing the previous command
  • Deleting ClientRegistry.blob in the steam folder and trying the above.

None of the above have worked. How can I get my TF2 server up to date?

2
  • When you say, do not work, what do you mean? You still get the same message? Or do the things you listed fail? I use the second method you listed, and it works every time.
    – smoth190
    Commented Aug 17, 2012 at 3:09
  • I have tried the above, and still get the same message.
    – NT3RP
    Commented Aug 17, 2012 at 5:46

3 Answers 3

1

_restart

or

quit

From my small experience of running tf2 servers I remember that you would need to reboot the server for it to kick off updates. Assuming you use the standard srcds_run Linux script, it should restart within 10 seconds. If you are using a server provider and you are still hitting a brick wall talk to them :).

2

This problem may be related to the steam.inf file not correctly updating.

Try removing it then retry an update (it's located in your orangebox/tf folder).

1

You need to supply the path to the Steam binary in order for the -autoupdate flag to work. Here’s how I do it:

./srcds_run -game tf -autoupdate -steambin /home/tf2server/hlds/steam +map koth_king

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .