0

I recently began having this issue where the controller turns itself off after being on and connected for 3-4 seconds and I have had this controller for 4 months now. I don't think it's a battery issue but the controller works fine when it's being plugged in (USB).

I have tried updating the firmware using the Xbox accessories app but it says I am not assigned and I need to plug it in to configure the controller.

Can this be solved? Thanks!

  • 1
    Your reason for your conclusion of "it cannot be the battery problem" tells me it is a battery problem. Why would you think it working via USB power means the battery is working? – Nelson Mar 18 '18 at 14:27
1

Answering to an old thread because this is one of the top hits for this issue.

For me the issue was caused by Geforce Experince and Steam. Controller stayed on if Steam was closed when turning it on. In order to fix it:

  1. Disable all sharing and overlays from Geforce Experience

  2. (I also disabled Steam overlay, I am not sure if it was necessary)

  3. Restart Steam

-1

Try turning off the device association service. It worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.